Binder font issue [with text colour not adapting to actual background]

Hi.
I don’t know if the same issue is present for Mac, but under Windows I just ran into somewhat of a problem…

For technical reasons, I have my binder’s background set to a relatively dark gray color.
Documents that don’t have a label (and therefor inherit the binder’s BG color) have their title displayed in a white font.

The issue is that when you are naming or renaming a document (so systematically in the case of a new document – which can’t possibly have a label assigned to it) the background for that document is also white, and therefor one can’t see what he/she is typing for a title.
The font should be black, no matter the BG color, when editing the title, IMO.

image

image

…and now you don’t :
image

Interesting.

This is not an issue with the Solarized Dark or Dark Mode themes.
image

image

So it’s theme-dependent.

I searched through the settings in File > Options > Appearance, but could not find one that impacted this, so it must be one of those underlying settings that @AntoniDol tweaks in the .pal or .qss files when he’s creating new themes. (I wish he’d come out with his theme book already, so I could buy it and learn how to tweak them too. :nerd_face:)

What theme did you start with? Perhaps if you began tweaking a different theme as the base you’d get a better result? That is, a theme whose “Binder entry” background color worked better with white text.

Or if @AntoniDol could tell you the correct file & setting to tweak, you could get your current customizations working better for you. :innocent:

Best,
Jim

2 Likes

None. → Default.
. . . . . . .

The Default theme is still a theme. :nerd_face:

Yeah, that’s what I thought. Default’s default colors for “binder data entry” are white background & black text –

But when I change Binder Background to a dark color, the text is automatically changed to white, but the “binder data entry” remains white–as you’ve already figured out.

image

So as a workaround, I still think you’d be better of starting out with a different theme as the base, one that already has “binder data entry” set to a dark color.

Of course, a darker base theme that might not work for you in other areas, so back to hoping that @AntoniDol provides the setting to change.

Best,
Jim

It is not dramatic.
Not so much of a big problem as things are ; but I think LL had to be made aware of it.

This said : yes ; if there is a quick fix I’ll take it.

2 Likes

My apologies for the delay on the book, guys. I’m working on a paid assignment for a fixed layout e-book. But it’s almost done, only have to convince Kindle to display the ePub3 properly. :woozy_face:

Binder text colours are notoriously difficult, because of the algoritm that swiches colors from white to black based on the tint of the background color. Apparently you’ve found a snag after changing to a dark background in a light Theme.

I’ll look into it shortly…

1 Like

Don’t worry about it.
I was able to fix it by using a light color made darker instead of starting off white.
(Or is it just that it’s now lighter? Perhaps.)
I get pretty much the same result, but the issue is resolved.

Color: #8f92c2

image

It is blueish, so as far as the technical reason I initially had for changing my binder’s background color goes, it is, by its contrast, just as functional.

No apologies necessary. :smile: Paid is good!!!

Thanks for the report. I think the best solution all around is to handle this the way some themes do before you change anything: match the background colour of the editing field to the binder background colour. It should just always do that, whether using the theme’s default or a user override in Options. That provides a better experience anyway, than a blinding white bar in the middle of a dark area of the screen that must be stared at intently while editing.

There doesn’t seem to be any option for that.
I guess I’d have to design a theme. (?)