I have a Scrivener project that I last edited in 2016, presumably with Scrivener 2.5. Now when I try to open it, I get an error dialog saying;

== begin

The document [name].scriv could not be opened.

The project at [path].scriv seems to be of an older format, but no binder.scrivproj could be found inside it. It may be missing or corrupt, possibly because of a problem with the device on which it is stored, or because of a synchronization problem.

Try ctrl-clicking on the project in the Finder and selecting “Show Package Contents”, then look for a file entitled ‘binder.scrivproj’. Ensure it has not been renamed by a backup routine. If it does not exist, try restoring from a backup.

== end

I did “View Package Contents” and there’s no binder.scrivproj, There is a [name].scrivx file however.

The project file is stored in Dropbox and I can open it with Scrivener for iOS. Obviously though I’d rather work on it on a real computer.

I tried editing the project in Scrivener for iOS and saving it back to Dropbox to see if it would open when it synched through to my Mac. I got the same error message.

In my Files folder I found a binder.autosave file. I renamed it to Files/binder.scrivproj and the project still wouldn’t open. I tried moving it to the top-level directory within the package and Scrivener offered to update my project, but then gave me a failure message. (I appreciate that it made a backup though).

What can I do? I could in principle edit on my iPad (where I’m running version 1.2.1) but I much prefer being able to use it on my Mac. I would be happy to install a previous version of Scrivener, but none of the v2 versions will run on my Mac (which is fully up to date and running MacOS Catalina 10.15.4).

All suggestions welcome.

Sorry to bump this, but this issue is making it impossible for me to edit my project on the Mac. The project is in Dropbox, but all the files are downloaded to my Mac. The iOS client is able to edit it but won’t compile to ePub as far as I can tell. Literally all I did was upgrade my version of Scrivener when forced to because the old version wasn’t compatible with my Mac and now I’m locked out. Happy to provide a zip of the project if anyone can help.

If no users comment on this it might be because you didn’t provide enough details.
Have you tried to contact L&L via their support mail?

Use the Export command from iOS Scrivener to create a ZIP backup of the project and email it to yourself.

On the Mac, unzip the archive – not in the Dropbox folder – and try to open the project. Does it work?

If not, open a support ticket, here, referencing this thread:

There’ve been some reports of strange behavior when upgrading iOS Scrivener - only projects to newer versions of Mac Scrivener.