Binder text doesn't appear

Text appears in outline and on corkboard cards but not when I click on the binder item. In this case no text appears, and when I want to compile files into one long printable text nothing happens. Already performed a restart.

It sounds like you’ve perhaps typed your work into the index cards entirely, rather than in the text editor itself. The index cards are meant to be used as a short summary for the section, and you’d click on the item itself in the Binder to type in the main text editor. In the past that would have meant laboriously copying and pasting, or doing something unusual with the compile settings. Fortunately the most recent version of Scrivener has a feature in the Documents menu, “Append Synopses to Main Text”. This will copy all of the card text you’ve written into the text files themselves. Now you should be able to click on them in the Binder and see their text. Try compiling once you see that.

I would recommend making a quick backup before you do so, in case you want to roll back if that wasn’t what you want. Just use the File/Back Up/Back Up Now feature.

Thanks. It works perfectly, though it says “send synopsis to main text.”

ssp

It seemed to have worked, but then when I re-opened the file, the changes weren’t saved. Am I doing something wrong?

ssp

So, all of the items that had text in them before are now empty again? Did you open up the backup instead of the one that was fixed?

I opened the one that was saved. I quit out of it. Opened it, and it had gone back to a binder with empty text

Good catch, it looks like there is a bug there. That command does not trigger auto-save for those documents, so they never end up getting written to the disk. If you go in and add a character to one then delete it, it will stay but the rest will empty out if you reload. I’ll let Keith know about the bug, but for now I devised an easy way to get around it for you:

  1. Select everything as you did before and use the menu command to copy the synopsis into text.
  2. Click on the Draft icon (or whatever folder all of these items are in) and turn on View/Scrivenings mode.
  3. You should see all of the text brought in from the cards. Select all, and then just hit Cmd-Plus and then Cmd-Minus to bump the font up and back down to where it was. This will be enough to trigger a save in all of the files.