Bit of an arcane problem with styles

I have two styles, Paragraph and 1st Paragraph. In theory they are identical except that 1st Paragraph is unindented. They exist in both Composition and Compile modes.

However, when compiled, text I italicise in composition mode is correctly italicised for the Paragraph style but not italicised with the 1st Paragraph style.

For the life of me I cannot find any difference in settings other than that 1st Paragraph had a little ‘a’ next to in in the style list, while Paragraph doesn’t (in Compile mode - both have the ‘a’ in composition). No idea how it got there (I get that it is some sort of embedded character style, but no clue how it got there or how to remove it). If I try to edit the style in Compile mode everything is greyed out.

Using the Novel Paperback format, if that helps.

So what am I doing wrong?

Edit: v3.1.5

Are you using styles on all text?

Why are you using styles for this at all? It’s trivially easy to tell the Compile command to not indent the first paragraph of a section.

Katherine

Um, I asked a narrow technical question.

The “trivially easy” first line un-indent didn’t work, I couldn’t see why and I had writing to do, so I made a workaround which has worked brilliantly up until this oddity.

It’s the oddity that I’m asking about: two apparently almost identical styles working differently, in an unexpected way.

If people would be kind enough to address that question. Then we can move over to “Using scrivener” and you can all explain how my life choices are wrong and what an idiot I am and how I should just move to a caravan in Wales and sell candyfloss for a living.

That is an important thing to be aware of, you’ll find information on the different types of styles in the user manual PDF, §15.6.2, The Basics of Styles. You are using a Paragraph+Character style for some of your paragraphs but not others.

Changing whether a paragraph style has character attributes as well: §15.6.3, Using and Managing Styles, under subheading Redefining Styles.

That said, I’m not sure if it is really the culprit here. Even full paragraph styles are designed to allow some forms of inline formatting to pass through, as naturally most people do want the italics, colours and other variations of text to come through.

No idea what that means, sorry. What is “compile mode” in this context? You’d normally edit the style in the Styles pane of the Format Designer, what you get when editing the Paperback Format itself. I’m struggling to think of any condition at all that would disable the entire interface.

Ultimately we might need a little more information to provide help. It’s difficult to create a scenario on purpose that works like you describe. Some screenshots of your compile settings could help, particularly what this disabled interface looks like.

I would hazard to guess it is because you had every paragraph styled in the document initially. Styles override most compile settings, putting the workload of formatting back on you. Leaving all body text unstyled leaves the rules of formatting up to the compile format, and easier to switch designs on the fly.

You could try it very quickly:

  1. Use the File ▸ Save As… command to create a temporary working copy you can dispose of later.
  2. In one of your chapters, select the entire text content and remove all of the styling from it.
  3. In Compile, use the stock Paperback format, not anything you’ve modified.
  4. Ensure the text of the chapters are assigned to a Layout, not “As-Is”. There should be sample text in the preview column which depicts the first paragraph indent suppressed.

And that should be all you ever need to do for most things. Maybe it’s more trouble than worth for this project, but something to consider for the future.

Right, finally had time to do some investigating.
Couple of notes first:
a) I was aware of the Paragraph/ Character Style distinction, I just didn’t (and don’t) know why a Para style seems to have an embedded Char style (but it turns out not to matter);
b) By Compile mode I mean the window that comes up after File>>Compile… Apologies - thought that was obvious.

HOWEVER
I can reliably reproduce the following using my 1st Paragraph style:
First - the pertinent text in is the form of a quote, (italicised because in-story it is broadcast, and needs to be distinguished from character dialogue):
It is in the form:
“Alpha Bravo Charlie, Mike November Oscar X-1234 seeking help, do you copy?”

  • Note that hyphen, which is a regular keyboard hyphen (ie minus-sign), not an n- or m-dash. This misled me for a bit: I initially thought that this was throwing the problem, because if I only italicised stuff either side of it then Compile rendered it correctly.
  • But when I removed it the problem returned and it turned out that if, with this style, I italicise more than half of the words then all italics get thrown out at Compile, and the hyphen happened to be bang-slap in the middle. Less and it is fine.
  • This obv, is a one-sentence para so I duplicated the sentence and the issue scaled with it.
  • The quotation marks and other punctuation appear to be non-pertinent.
  • But to keep a spanner firmly in the works, regular Paragraph style does not exhibit this issue - I can italicise as much of it as I like it in Compiles as expected (position doesn’t matter - it is the selected style).
  • OK, so I’m doing it ‘wrong’ but it still baffles me as to why a style might behave like this.

(BTW, this came up because, having worked with text in various tight-deadline environments for many years, I learned to brute-force things when software didn’t behave as expected, the inbuilt solution wasn’t immediately obvious and time didn’t permit reading a manual. There isn’t a staff writer or sub-editor in the world who isn’t used to this.

With that in mind, I commend the idea of putting some time in your roadmap to let your designers give deep thought to discoverability for the benefit of those in a hurry, or long-time Mac users with a pathological aversion to manuals - or, um, both)

I’m still a bit lost on the description in that case. There wouldn’t be any place to edit styles in the compile overview (what comes up immediately after using the command). So I’m still not sure what you are changing, or what would be grayed out. Perhaps it is not terribly pertinent to the main issue though.

It might be most efficient to share a little sample material with us. If you cannot send the entire project to support for whatever reason, then what may work just as well is to use File ▸ Save As… to create a disposable copy, delete everything but an item or two to demonstrate the problem—and further if need be, use Edit ▸ Find ▸ Project Replace… to scramble the text up a bit (switching letters around shouldn’t mess up the sample). Send a zipped copy of that in to our support address, and provide the forum thread URL so whoever gets it can flag me on it.

I’m trying to set things up the way you describe, but I’m not getting the same result.

Yeah that’s a surprisingly difficult thing to do. :slight_smile: The problem is that those in a hurry, as you put, are by definition not trying to learn the software and thus using pathways they are familiar with from entirely different tools. I think we do a pretty good job of that overall. Consider you can use Scrivener without even knowing what a style is, or you can use it knowing what styles are and get a simple result sticking to the stock stylesheet. Or if you know what styles are and try to design your own look top-down as you have, that should also work without having to learn much.

I think it is important to not conflate what in all likelihood looks like a bug, or a very edge-case problem, with the mainstream experience of learning (or not learning and just brute forcing) a program. What you are describing isn’t how the software should work. It should let you manually style every paragraph by hand and it should be pretty WYSIWYG for the most part, working that way. It’s not the most efficient approach, and it is not “the Scrivener way”, but like I say—it’s a pathway built into the software specifically to accommodate those who don’t have the time or inclination to learn it from that angle.