"\*\bkmkend" marker in rtf files (integrating with Sente)

This is really down in the weeds, but maybe Keith or Ioa can help…

So I am working on my document, and I need to process it using Sente, a bibliography management system. In order to use Sente you use markers like “{Smith 2010}” in the document and then “{Bibliography}” at the end. Sente replaces the first with a citation (like “(Smith & Jones, 2010)”) and then in place of the latter marker emits a bibliography formatted properly in the style you requested. Sente can deal with .doc files (only by leveraging off Word 2004), .docx files, .pages files, and .rtf files.

I am using .rtf files. My protocol is (1) compile in Scrivener to .rtf, (2) edit the resulting file in a word processor to tweak it, (3) process that file in Sente, (4) open the resulting .rtf file in a word processor and print or convert to pdf.

The problem I have is that Scrivener is not emitting the .rtf code that Sente wants for the “{Bibliography}” marker. The final lines of my file should look like

References {Bibliography}

What Scrivener emits is

\page {\*\bkmkstart References}}}
{\pard \s74 \ql \widctlpar \nisuskeep0 \nisuskeepn0 \sb0 \sa0 \sl600 \slmult0 \ltrpar \pardirnatural \li0 \lin0 \fi0 \ri0 \rin0 \tx560 \tx1120 \tx1680 \tx2240 \tx2800 \tx3360 \tx3920 \tx4480 \tx5040 \tx5600 \tx6160 \tx6720 {\f1 \fs28 \AppleTypeServices \b References{\*\bkmkend References}\par
{\pard \s74 \ql \widctlpar \nisuskeep0 \nisuskeepn0 \sb0 \sa0 \sl560 \slmult0 \ltrpar \pardirnatural \li0 \lin0 \fi0 \ri0 \rin0 {\f0 \AppleTypeServices \b0 \{{\*\bkmkstart Bibliography}Bibliography
{\*\bkmkend Bibliography}\}\nisusselectcaret \par }}}

It appears that the “*\bkmkend” part confuses Sente.

I can work around it by (a) opening the rtf in Pages or NeoOffice and editing the .rtf file. Both of these programs remove the “*\bkmkend” part upon saving, but they also screw up the .rtf in other ways that are objectionable.

Or I can open the compiled document in Nisus Writer Express, which really seems to understand the .rtf format, and then delete the “{Bibliography}” string and retype it, which gets rid of the “*\bkmkend” in the rtf file.

I don’t know what the “*\bkmkend” is doing in the .rtf file, but if it can be omitted, or (I suspect) if it could be outside the left curly bracket of “{Bibliography}”, it would make my life easier.

If the “*\bkmkend” is representing something I have control over in my Scrivener file, please let me know.




The first thing I notice is that the RTF code you posted was generated by Nisus and not by Scrivener. Once you open an RTF file in another word processor and save it again, the file is completely updated using the RTF writer of that program. Nisus’s RTF-writing is superb, so we can at least rule out bad RTF here.

If you look at this code:

{{\*\bkmkstart Bibliography}Bibliography {\*\bkmkend Bibliography}\}

All this means is that the word “Bibliography” in the text “{Bibliography}” should be treated as a bookmark ("*\bkmkstart Bibliography}" tells the word processor, "Here begins a bookmark entitled “Bibliography”, and “{*\bkmkend Bibliography}” says, “That’s the end of the book.” Bookmarks should be treated as normal text, except that you can use the bookmarks panel in Word or Nisus and certain other word processors to navigate straight to these sections of text. So this looks as though it is a bug in Sente, in being confused by bookmarks.

Fortunately this is easy to prevent, though. Scrivener adds bookmarks by default to document titles, so that the document will be easy to navigate when opened in a word processor (in Nisus Writer Pro, for instance, you can show a list of bookmarks by going to Insert > Bookmarks > Show Bookmarks in Navigator). But you can tell Scrivener not to add bookmarks. To do so, when compiling, in the “Formatting” tab, just deselect this option:

You’ll need to deselect that for each formatting type affected.

Hope that helps.

All the best,

I feel like you are a guardian angel, finding each problem that I encounter and giving me a fix before I need it.

Thank you

Glad it helped! :slight_smile: