Blank Documents in 024

I believe I have found a bug. I didn’t see it on the known issues list.

I was creating my own character template in a saved Novel folder, by copying and pasting a lengthy amount of text from a MS Word 2003 document into a duplicate copy of the character sketch template. I wanted to look at the information from the original character sketch template, which I had left intact, but when I opened it, it was blank. So was the setting sketch template, as well as a copy of the setting sketch that I had previously saved to a separate “worldbuilding” folder.

By the way, I only realized that my copy of the setting sketch was blank because its little thumbnail in the folder tree had no little text lines in it. (I did find it quite charming and useful that the blank documents had blank thumbnails and the doc with text had tiny lines in its thumbnail, despite my pique over this bug. I’m a first time user of Scrivener, so there’s quite an ooooh! factor with all the discoveries…)

Hi bookworm,

So sorry I didn’t catch this one earlier. Blank documents do not sound good! Was this project created from the Novel template in the 024 beta? Did all of this–duplicating the file in the binder, pasting in text from Word, then returning to the original file to find the text gone–happen in one session, or did you close the project in between? Are you using any sync or backup services that were running when you were working in the project? Sorry for just throwing a bunch of questions at you, but I do definitely want to track down exactly what happened to make sure we can keep it from happening again. Also when you say that the setting sketch template and the a copy of the setting sketch template were blank, were these both (prior to being blank) just containing the default template text or had you added anything to them? (With this, I’m assuming this is all in a single project, and that the “world building” folder is a folder in the binder that you moved or copied the sketch to.)

As for the binder icons–yes, I think they’re pretty cool, too. :wink: There is a mild refresh bug right now so occasionally the icons don’t always display properly when you load the project–sometimes it will show blank when it’s got text or vice versa kind of thing–and then correct themselves when you click on them, but that will get fixed and meanwhile it doesn’t at all affect the contents; it’s just a matter of whether the right icon is showing.

I’m glad you’re having fun with Scrivener! Thanks for reporting this, and welcome aboard!

Hi MM,

Thanks for your reply! I certainly don’t mind all the questions.

Yes, I used the Novel template from the 024 Beta to start a new project because I wanted to use the layout and content of the character and setting template pages. The work was done all in one session, so I didn’t close the project in between. I don’t recollect if I saved after each step. I wasn’t running any sync or backup processes. (I’ll explore the tips in the forum for recommendations for different options on how to do that, so I safeguard my work product next time!)

The setting sketch template and the copy I made each had the default template text. The only difference between the two was location (you understood correctly, I dragged the copy to the “world building” folder that I had created in this project), and title (“Main City”).

The character template I had made for myself was text in outline format which I copied and pasted from Word. Some of the original Word document was text I had typed in directly, and some of it was from other documents, so maybe there was some weird formatting that got dragged along with the text?
It was pretty long (about 7 pages), but it had a lot of white space. If I can think of any more information I will let you know. If you have any other questions, please do ask.


Hi again,

I wrote about vanishing text recently from version 24. Here’s the update. Nothing worked to recover the text, and the documents remained blank. Then I tried starting a new project, but this text also disappeared after clicking on the icon (which had the depiction of writing before clicking on the icon, but then went blank.) The text vanished from nearly all the documents while the file was kept open for a few days.

I’m afraid I’m going to have to sit out the rest of the beta trial and revert back to the Mac 2.0 version until this issue gets sorted out.