Blank documents in compile and export

Hi Keith

I too am unable to compile. I am using 2.0.45 with Mac OS 10.4.11.

Here’s a step-by-step of what happens:

  1. I have three documents inside the “Main Content” folder. I created them on the Corkboard but have edited them in outliner mode.

  2. I hit the Compile button; so far I have tried this with three formats: pdf, rtf and plain text. I have used both Original and Custom formats.

  3. The usual file-save dialogues appear and the progress bar indicates that the compile has finished.

  4. When I look at the resulting file in my text editor or pdf reader, the title page appears, but there are empty pages where the content of the document should be. However, the Notes page appears, as does the Works Cited page. With the latter, the original placeholder text does appear (i.e. “Works cited should go here (this page is optional). See the Works Cited Format document for information on formatting citations.”)

  5. Interestingly, the same thing happens when I try file>export. The export produces the files corresponding to my Scrivener documents, but the files themselves are blank.

I’ve moved this issue to its own thread, since it was not related to the original Tiger compile problem in the other thread.

Quick question, when you say there are blank pages where the documents should be, does this mean you have a certain quantity of pages, proportional to the length of these documents? In other words, do you have 50 blank pages in some chapter, or is the entire chapter just one blank page?

Pardon if this is a basic question, but when you click on one of these documents in the binder, so that it is the only thing selected, do you have any text? I’m just wondering if you have the bulk of your text in the synopsis field (index card fronts). That would explain why you get nothing on export or compile, since the synopsis is a summary of the document, not the document itself.

Thanks for your answer. It does indeed appear that I have made a newbie mistake. When I did a compile which included text from documents as well as from the file cards, the text from the documents did indeed appear. I guess I’m a little confused about the interface and the difference between documents and file cards; I had thought of them as different views of the same content. I’m sure I’ll be back later with more dumb questions. :blush:

The cards and the document are linked, so it’s an understandable mistake. Think of it more like a physical index card paper-clipped (maybe stapled, that sounds more permanent) to the full-page paper. The index card has the brief synopsis; the other page contains the full document. They’re both about the same content, but one is the three-sentence summary that you whip up so you don’t have to read the whole document to know what it’s talking about. (Or conversely, maybe you jot down a few notes on the index card first, to remind yourself of what you want to write in the document later.) In Scrivener, the two are always stapled together, but in some views–Corkboard and Outliner–you’re only looking at the index card text. In Scrivenings mode or regular document view, you’re looking at the document itself (though the index card synopsis is available in the Inspector). But when you move around cards on the Corkboard or titles in the Binder, you’re always moving both the index card and the whole document.

I don’t know if that helped any, but it let me procrastinate for a few minutes. Whee. If you haven’t yet, definitely go through the Tutorial (or even if you have, it may be worthwhile to look through parts of it again), since that explains the concepts and lets you actually work with them right in the project to get a better understanding.

Hi - I’m having what seems to be a similar problem, but I can’t sort it out based on what I’ve read thus far. I’m going through the Tutorial file and am at the compile step (#17). If I try to compile to pdf, it generates the right number (I suspect) of very narrow, empty pages. If I compile to rtf, it seems to perform as I’d expect. I’m running 2.0.4 on 10.6.6. Thanks!

Hi.

I’m having compiling trouble as well. On the chance it’s related to Keith’s question, I’m posting it here, with apologies if it belongs in a separate thread.

Since I upgraded to 2.04, I haven’t been able to compile documents that have text in them. Here’s what happens: I check various documents contain text (and which I’ve successfully compiled before) and then click “Compile” (and then “Export” if I’m exporting to Word). Then nothing happens. The progress bar shows no progress (which is unusual) and the Print dialogue box stays up (although I can leave it without having to escape), and nothing has compiled or exported. I’ve tried compiling a PDF, RTF, and Word document by checking off Included Documents, Excluded, and All. The only time a compilation is made–and the progress bar operates normally–is when I have no documents checked off, and this only results in blank compilations.

Also, when I try loading the settings that I’ve created, which include text documents, I get the message: “The specified compile settings could not be found on disk.”

Many thanks for any help!

-Krios

I’m having exactly the same problem as Krios since updating to Scrivener 2.0. I’ve tried compiling several times to different formats, but every time the dilogue stays open and nothing happens.

I am working on an iBook running Mac OS X 10.4.4.

Krios and nessie222 - yours is a different problem to Keith’s. A bug crept into 2.0.4 that causes Compile to fail on Tiger. Please download the 2.0.4.5 beta from the following thread, which fixes the issue:

https://forum.literatureandlatte.com/t/scrivener-2-x-update-betas-download-here/11262/1

(Just download it, unzip it, and replace the version of Scrivener in your Applications directory with the one above, and you should be good.)

Keith - do you have any strange page settings at all? Try going to File > Page Setup > Settings > Scrivener, and check the margins (also check the paper size).

All the best,
Keith

I would check the Formatting compile option pane as well, as you can have it change the indents for a text you are compiling. Perhaps one of the opposing sliders got moved all the way over to the left or right on accident. If the little checkbox as the top of the pane is not enabled, then this isn’t the problem. If it is checked, try deselected it and doing a test compile again, see if that clears up the problem. If it does, you know where it is.

Keith–the beta solved the problem. Hurrah! Many thanks for your help!

Best,
Krios