Blank line separator not centered


When I go to compile, the separator is no longer centered. I’m not sure how this has changed. If I try another compile format it’s still the same problem. I do have one format were I try to use ***, but even if I use another format and there’s the #, the problem is still the same. I have tried uninstalling scrivener, and reseting to default, but it still hasn’t changed.

When you say the separator is no longer centred, does that mean it is typed into the editor by hand instead of inserted by the compiler automatically?

If so, you probably just need to put a style on it to protect the formatting. Scrivener can’t know that because you typed in * * * that this is supposed to be anything special, so it tries to treat it like any other paragraph. The “Centered Text” style that ships with the software’s default settings is designed for just that purpose.

It’s not typed in the editor, but I definitely know this is some formatting issue. Basically, I want to have the three stars, centered, after a line break when I compile. At the moment, the # ends up aliened to the left.

Okay, so you’re typing this into the Separators compile format pane as a custom separator then? There aren’t many factors that would cause that to end up left aligned, and the only ones I can think of would be so deliberate you’d know you did it (like overriding the default CSS in an ebook).

It would thus help to know more about your compile settings, like what file type you are creating, and which Format you started from when making a custom one, and potentially even what program you are using to view the results.

What’s weird is that this is happening with original compile formats I thought I couldn’t change (duplicating and then editing the duplicate.). Is it because the line break is formatted to be left aliened? I’m using the novel with parts template.

All right, well sometimes the best way to figure something out is process of elimination. I’m attaching a novel-with-parts project that is stripped down to the essentials, with a little junk text. There are some scenes in sequence in the binder, as well as some empty lines, to test both kinds of separator. (36.7 KB)

When you compile this, you can use the stock Manuscript (Times), and as well the Manuscript (Times; Asterisk Separator) format that I created, to test customisation. For myself, both of these RTF files come out as expected. All of the separators are centre-aligned.

So the idea is to look at that and see what is different about how that is working, and what you’re doing. This is a default project, nothing has changed that would impact compile, save for making a custom format and adding some gibberish text.

Hi, Thanks so much for this. I tested it, and all the separators came out center-aligned. I just don’t understand how I could’ve changed anything on a scrivener compile format.

If you can’t find the difference between the projects, I could maybe take a look at it. Feel free to zip it up and PM it to me, or if you’d prefer you can send it to the official support channel and refer to this thread URL so they can alert me.

I used the compile format you gave me on my project, and it came out with the same as the “junk text”. I compiled again with the Manuscript (Times), and the # becomes left-aligned when I use a line break. Is that how it is formatted? For some reason I thought the # were always centered. I didn’t think I could change the an original scrivener compile format, either.

Thank you so much for you time!!

Oh weird, so the custom compile format I made works in your project but not the built-in one? I only changed the “#” to asterisks in that one… hmm, well make sure you copy of Scrivener is up to date, maybe there was a mistake in the format in the version you have. You can run an update check from the main Scrivener menu.

Yeah, it is weird. My version of Scrivener is up to date. I guess we could see when the next update comes?

You could try trashing your current copy, and then re-installing from a fresh download. Sometimes bits get flipped through nobody’s fault. Anything from a single transistor malfunctioning (out of billions in the typical computer), to cosmic rays (seriously: Cosmic Rays Can Harm Computers, but Experts Say We Don't Need to Worry and everything in between.

Both extremes are highly unlikely to be the actual/only cause, but there are countless points at which failures can be introduced – including errors during the last download, introduced as the Scrivener software is passed through several internet routers on its way to your computer.

I did try that already. Maybe I can try, again.