Block insertion point?


I am trying to configure Scrivener to have a “fat” block insertion point like the one in Write Room. Right now I have a narrow block, like a fat letter I. I am trying more for a square.

Been fiddling with the “px” box next to “Use block insertion point of…” but to no avail. Doesn’t seem to be responding to values in there. Put in a ridiculous value of 100, no change, put in another ridiculous value of 2, no change.

Must be missing something but I’m not sure what.

Any help would be appreciated.


Since you mention WriteRoom, are you trying to set it for Composition Mode? If so make sure to use the “Compose” preferences. The “Editor” preference tab is where you would set it up for the standard editor. One other thing worth mentioning is that this setting is for the editor, it won’t impact various other fields such as the Title, Synopsis or Notes.

Yes, I am in the Composition mode prefs.

Ah, I see the problem. It looks like that is a minor issue that occurred when some experimental changes made to a beta were reverted. One of the changes was that there would only be a single setting for the width of the cursor, while still allowing you to choose independently whether each mode would have a block cursor. Although the preference interface got rolled back, the underlying function is still only using the one width setting in the Editor tab. If I change the main editor width to 12px, and then load up Composition mode, the change is in effect. So change it there, and then if you want, you can disable block cursor for the main editor—Composition mode will still go on using that setting for the width, even if the field is disabled for editing.

Brilliant! That worked! Thanks so much! :smiley: