Bluetooth mouse cannot scroll consistently in Full Screen

Hello,

I think I may have a minor bug here.
I am using a MacBookPro 2.8 Ghz Intel Core Duo with 8GB 1333 MHz DDR3
Mac OS 10.7.5
I am running Scrivener 2.4.1
I am also using a USB keyboard (german) and a bluetooth mouse (Apple).

Here is what happens:
I go into Full Screen mode with either an existing text or a blank document.

  • If the document is empty or contains text that does not fill the page, I can scroll with my mouse both up and down (but since there is not enough text to really scroll, it will just bounce slightly).

  • if the doc contains text that goes beyond what the screen can display,
    a) if I am at the top of the page, I can scroll up but not down (scrolling up: the text will just bounce down slightly, since there is no text above to be revealed, but nothing will happen at all if I attempt to scroll down)
    b) if I am at the bottom of the page, I can scroll down but not up (same in reverse)
    c) if I am in the middle of the document, I cannot scroll at all

I can, however, move with the arrows or ‘up’ ‘down’ keys on my keyboard.

This is what I found in Console:
10.08.13 19:46:56,514 Console: Can’t open input server /Users/username/Library/InputManagers/Edit in WriteRoom
10.08.13 19:46:57,270 Console: Could not find image named ‘BackArrow’.
10.08.13 19:46:57,270 Console: Could not find image named ‘ForwardArrow’.

Sorry: I just found out that the same applies if I want to scroll using the trackpad of my laptop. So this is not specific to the Bluetooth mouse after all… Maybe the bug was filed elsewhere then.

My Full screen settings are such that no scroller is visible.

I hope this helps.
Mathilde

Since you mention this happening primarily in full screen, do you have the option selected in the Editor preferences pane which causes the editor to be fixed-width and centred within the screen, while using full screen? If so, what happens if you toggle off centred first, and see if the problem persists, then toggle off fixed width and test again. Any change in the behaviour?

Hi Ioa Petra’ka,

Thanks for your response. I indeed had both ‘fixed width’ and ‘center’ selected in the Editor preferences.
I tried exactly what you suggested: first toggling off ‘centered’ and then ‘fixed width’ but no change in behavior in either case.

I did notice something though: If I am in Full screen (I actually mean Composition mode, I hope that was clear) with ‘minimalist scroller’ selected (in the Compose preferences), all goes well, I can scroll. – If I change the settings to ‘No scroller’ WITHOUT LEAVING the Composition mode, all still goes well, I can still scroll. – If, without changing the settings, now set to ‘No Scroller’, I exit Composition mode and go right back in and try to scroll = not possible anymore.

Also, I am just noticing that the ‘Auto-Hide’, ‘Minimalist’ and ‘No Scroller’ settings all look and behave exactly the same, except that I can’t scroll in the ‘No Scroller’ settings as described above.

Mathilde

Ah, yes there is a substantial difference between full screen and composition mode. The latter is not at all impacted by the two settings I advised you to try earlier; you can go ahead and put them back the way they were. Those will only come into play if you use 10.7’s system full screen mode on a standard Scrivener window. Okay, I have played with this in Composition mode, using the various scroller settings you described, and can reproduce the problem with my 10.7 machine as well. So this looks like a bug we can at least track down and that means it should be an easy fix. Thanks for the report!

Glad I could help! Sorry for the mixup with Full screen/Composition mode.

No worries! I still forget myself sometimes, too. It was “full screen” for so many years, and the Windows version still refers to it that way as well. :slight_smile: