Blurry Rendering

I find that when I use Scrivener on my iPad, often lettering go blurry. Everything but the editing space is clearly rendered. But the main text always seems slightly blurred. I thought this was a font issue, but it happens with several fonts. Just thought to report the bug.

Have you tried tweaking this option ?

Inked2022-03-21 11_33_36-Options_LI


Or perhaps try a different zoom level in the editor ?

A good thought for Windows, but none of that is going to be available on an iPad, though. :wink:

As for the report, we’d need a precise checklist of settings to adopt, starting from default text and zoom (try resetting a copy of the tutorial and working from that), as well as your iOS version. I won’t give you any false hope though, Scrivener has zero lines of code that display text on your screen, at a level that would determine whether it is fuzzy or not. That’s all coming from the system. If we can see it though, maybe we can see what is going wrong and fix it, or least let Apple know about it.

I would think non-integer font size (either by font size directly, or by zoom, or by a combination of the two) messing up the font display vector.
(I say that to make up for my previous mistake :wink: - and because it is nerdy, just like I like it.)

Yeah, that’s what I’m thinking as well, and that could be achieved by a combination of the font size and editor zoom factor. But a full run-down of settings off of default would be best, just to avoid a bunch of back and forth.

It looks fine to me with default settings, so what do I need to do to make it look bad.

My apologies for the delay in response. Just had some other work to attend to. I just want to clarify the bluriness goes away when I zoom in and out. So really it’s not a big issue. I just thought it a small bug, which I why I decided to report it. I have the last iOS version, and the blurried font comes up regardless of the default font and size is set. But as I said, it goes away when you zoom in and out. Just thought it looked bad for a product that as a default setting, blurry fonts.

So the tutorial, with its Palatino 13pt font and 1.2x magnification setting is blurry for you on load? It’s perfectly crisp for me, so there may be some other core setting you are using that would impact the display of it, that I’m not using. What is a run-down of your main Scrivener settings? I’m thinking the Appearance, Editor and potentially Backgrounds sections might be pertinent.