Bold / list bug?

hi there,
thanks for looking into this.
I’m using Scrivener 2.0 (pretty great so far!) on the latest Snow Leopard version on a Mac.
I’m not sure if this is a bug but it sure feels like one. (or is there some setting i should change?)
If I make the first line on a text note bold (as title) , and then start a list of bullet points below it,
all the bullet point text I type in defaults to bold. So far so good. Everything is OK if I switch off the default/automatic bold mode (by simply changing the font to normal, just as I can do in Word) BUT I can’t (at this point Scrivener behaviour diverges from Word, which I’m taking as a benchmark). If I turn the bulletpoint text back to normal text, and then press return to get the next line/bullet point, the next line still automatically defaults to bold. The only way around this is to leave a buffer zone at the end of the list with the can’t-switch-off bold default mode there while the normal mode is on above the buffer zone. This works, but is a bit annoying to use and not smooth, since I have to set it up and delete the “buffer” each time .

I can reproduce this behaviour. I’ll reduce this to a set of steps so the developer can determine if it is even something that can be fixed (lists are Apple’s code, and they are notoriously buggy and difficult to patch up). One thing in favour of it not being a straight Apple bug is that it doesn’t reproduce in TextEdit. That’s the gold standard. If what you are seeing also happens in TextEdit, then it’s probably Apple’s fault and very hard to fix. Comparisons with Word are, while thematically useful in terms of the genre of text editing, technically mismatched, because Microsoft does not in any way use the Cocoa RTF engine like Scrivener, TextEdit, and many other Mac programs.

  1. Cmd-N to create a new document; switch to editor
  2. Cmd-B to set bold type; type in “This is my title”
  3. Cmd-B to set standard type; press return
  4. Select bullet list type; format bar reports bold again; hit Cmd-B to reset again
  5. Type in “There are many like it but this one is mine”; formatting should be standard
  6. Press return
  7. Type in “My title is my best friend”

Second line is bold.

Repeat these steps in TextEdit; none of the Cmd-B resets above are necessary. The first one suffices to permanently toggle the formatting mode.

Work-around: A buffer space is one, like you said, but a better one is probably just adding a second carriage return on step two. Turn off bold when you are done typing in the title, then hit the return key twice. It is fairly normal for titles to be offset from the body text, so this shouldn’t be too bad. Also, this is all very easy to fix after you type it all in. Just ignore the glitch, and once you’ve finished up the list, select it all and hit Cmd-B to reset to standard.

Thank you for the very rapid and comprehensive response to a minor bug. Most impressive! :smiley:

Strange - I can’t reproduce this at all, and I followed these instructions exactly. For me, in Step 4, the format bar didn’t report bold after I had created the bullet, so I didn’t need to reset to normal text - the bullets weren’t emboldened. I chose the bullet from the format bar - did you create it a different way?

What fonts are you both using? That could be a factor, I suppose, but I tried with both Optima and Helvetica and both worked fine for me.

Thanks,
Keith

It’s not font family. There is some strange ingredient that is causing it to not always happen. I was just trying to narrow it down to fonts and so was thus playing with font settings and sizes and families, and suddenly it stopped reproducing across the board. Even with the exact same conditions as yesterday (Adobe Garamond Pro 14pt / 1.1x) where it popped up a dozen times: nothing now; even after a Scrivener restart.

Hmm.

I think this is more likely to be a text system thing anyway. As far as bullets and bold is concerned, it’s all handled at the OS level. Lists are a black box.
All the best,
Keith

Yeah, I agree, I was really rather surprised when it didn’t show up in TextEdit, but I only tried a few times. Given that it seems to require some Magical ingredient (and we all know who makes those), it might eventually reproduce in TextEdit, too.

might be a bit late now, but fyi I was using optima or helvetica throughout.