bold text in compiled draft

Hi,
I hope my english is good enough to understand :slight_smile:
I’m from Germany.

Since I updated to 1.71 a few days before, the bold text isn’t bold anymore in the exported pdf.
in the former version bold text was exported as it should be.

I only found the – preserve formatting. But I don’t want the text style from the scrivener document, only bold formatted text (and italic. that works fine.)

I hope, you can help me :wink:

Thanks
Alec

Bold text should be preserved through compile even when you have “Override text and notes formatting” enabled. Could you share your compile formatting settings and also check in the Import/Export options to see which converter is being used for PDF export? (Both options should work, but it would be good to know which you’re using.) Is this something you see just in your one project or can you reproduce it starting from a new blank project?



Hi MM,
I have the same Problem with a blank project from scratch. Only two lines, one bold one normal.
Export settings: “Paperback Novel”
In the options I have default: PDF Export via Scrivener.
When I export as DocX the same Problem happens.

In the dialogue for Export / Format The text an comments formatting override box is checked - in both projects.
(I have the german program-translation… comments may be the wrong word)

I admit I’m really running out of ideas here. :neutral_face: What if you choose the “Original” compile preset instead of “Paperback Novel” (that will export without overriding the font or making other changes to the formatting–it should be retaining the bold either way, and is doing so when I test it on my machine, but we can test it by eliminating that from the process). If you have Microsoft Word 2007 or higher installed on your machine, try changing the PDF export option to use Microsoft Office and see if that makes a difference.

Hey, MM
Now I have the solution. The Checkbox has to be unchecked (see picture).

Problem solved. :slight_smile:
Thanks
Alec

… Ah, but now its not formattet in times.
Big trouble :wink:

I think I will take it without text override settings. Maybe there will be a version 1.7.2 or so for my bold text :wink:

Thanks for trying that; it at least gives some focus to the problem. Bold, italic and other character formatting should be preserved during compile even when “Override text and notes” formatting is enabled, so there’s still something not working right for you.

What font are you using in the editor? Could you zip up a sample project (with the compile settings producing the error) and attach it here so I can see that directly? Also, what program are you using to view the compiled document? (E.g. Word 2007, OpenOffice 4.1.0).

Something else to try is uninstalling and then reinstalling Scrivener, especially if you installed via the auto-update or over an existing version or had the beta installed side-by-side. With the changes in the export converters, it’s possible something got messed up there so that the export isn’t using the updated converters as it should. You can save your preferences via the “Manage” button in Options and then reload them after the reinstallation so you won’t lose those.

Here it is.
custom compile settings are named: “problem with bold text”

I use adobe pdf 11.xx (the actual version) to view pdf
and word 2010 for rtf an doc / docx.

So if you don’t get the same problem with the zip file, I will reinstall scrivener.
problem alec bold text.zip (597 KB)

Yes, the bold text looks fine when I compile without changing your project settings; I tried both PDF converters and it compiles correctly (viewing in Adobe Reader XI also). Same for compile to DOCX (checked in Word 2013). So I’d try the uninstall and reinstall to see if that fixes it.

Completly reinstalled from scratch.
Thanks for the infos to save my settings (e.g. my personal wordlist and compile settings).

Everything works. Bold text ist showed in PDF as before.

Thanks a lot,
Problem solved.

:smiley:

Phew! :slight_smile:

No sorry not solved…

I had the override checkbox not activated.
with activated bold text dissapears in compiled pdf.
As rtf document with word 2010 opened I have the same problem.
mysterious…

Is this always using the “Paperback Novel” preset? What happens if you choose the Original preset, and then just select the “Override text and notes formatting” option in Formatting? I’m not holding out a lot of hope given that I didn’t have any problems with the project you attached, so if it was buggy settings in that I’d expect to have experienced the same, but we may as well check. :neutral_face:

Ah, other question: Do you have any anti-virus software running? If so, check with that to see if it’s flagged or quarantined any files from Scrivener. There’ve been a couple cases in the past where something like BitDefender flags the Doc2Any converter Scrivener uses (it’s called, for instance, when using the “Microsoft Office” export options) and that prevents a proper compile. I’d have expected more fanfare when trying to compile, but again, it’s worth checking.

Oh also, something I meant to check on earlier and then forgot about–could you run the compile to RTF using the sample project and attach the compiled RTF here? Also try what I suggested previously, compiling with the override enabled but not using the Paperback Novel preset–use a different font in the compile format, other than Times New Roman. One possibility is that there’s a bug with the font, so it’s not showing up bold on your machine but appears fine when I run the test on a different computer.

Thanks for your answhers.

I have antivir from avira running. it shouldn’t change docs. Or get such deep into the system (converters) as some other software does.

Here is a rtf. First line text ist normal, second bold. – ah rtf is not allowed to upload. epub too. And HTML… grmbl.

Same error with overriding. No Times New Roman.

What is the standard compile name?

Now I have compiled some test documents.
As html. bold text in html is simple as it could be. :wink: But there is no bold text.
I triede epub. Only italic.
In Manuscript the italic text is underlined, as it should. Bold text - like before. No bold characters.
It seems to be the override function, because without it works. In PDF, RTF, DOC, DOCX etx.
Hmmmm.

No, I tried my own and 3 or 4 other presets.

You can change the extension or right-click the file (or multiple files) and choose “Send to \ Compressed (zipped) folder” and then attach the zip; the forum should accept either.

Here a graphic with output as preview.
Same Problem. There should be no chance for any antivir-software to change bold to normal?

ah ok. here is the zip file with some examples. named by compile settings.
test.zip (6.33 KB)

Aaaahhhh I have figured it out. It’s the translation. Something must be broken in the translation hookup in compile, and the bold text is not coming out. Try changing your interface language to English and compiling again.

I’ll let the devs know. We’re in the process of getting updated translations, so this might already be fixed by that. Thanks for your patience!