Border around inline annotation missing after table

Version 3.1.4.0. When a table is inserted in the editor, inline annotations before the table get the customary color change and border drawn around them. After the table, the inline annotations get the color change, but there is no border.

I haven’t tested it, but perhaps try and change the font color of your inline annotation.
This might reset the border if it got confused with the table’s.

(Just a hunch.)

Changing the color of the annotation doesn’t get the border drawn. Neither does changing the font.

What if you move or copy one from above below?

If a paragraph containing an inline annotation with a proper border before the table is copied to after the table, the border disappears, but the color remains.

Click in the following paragraph.

Or zoom in then out, one notch.

Manually tweaking the width of the editor also fixes it for me.

Or navigating back then forward.
image

??


. . . . . . . . . . . .

I can make the border disappear at will. It disappears when I select text in its paragraph.

It only does it for the annotation(s) of the first paragraph with annotation(s) following the table (or up until you have a paragraph that’s without an annotation). And once it is fixed, it remains so until you select text in this one paragraph.
So it’s not so bad. You just need to know what to do.

It is clearly a bug, but that should allow you to work undisturbed in the meantime.

I tried all those things you suggested. No change for me. I think there is definitely a [re]draw bug here, particularly since you and I are seeing different behavior from the same actions.

I really appreciate that you’ve taken an interest and have tried to help me, but at this point, I think I’m just going to punt - I hardly ever use tables and I really need to move on.

It might also be something that is resolved in 3.1.5 since the QT libraries are being updated. I’m just not in a place that I can check the beta.

I ran my test using the beta (my mistake, I’m still waking up). So perhaps that explains the different results we get.

[EDIT] I get somewhat the same results in 3.1.4. Also note that isolating the table in its own document and displaying the whole as a scrivening clears the issue away.

1 Like