BUG - Beta30 - Corkboard wierd display of characters

I am setting up a list of characters in a new work. I created a character, named them in the document, then duplicated and renamed five times. I then created a folder and moved the characters into the folder. When I look at the folder using the corkboard it only shows the last two characters (see picture 1). However, if I click where one of the missing ‘notes’ should be it appears (see picture 2). And then when I click on the next missing ‘note’ it appears but the other one disappears (see picture 3)…

It turns out that if Scrivener doesn’t believe the missing characters had been named (see the absence of the name against ‘Mouse in picture 2’. If I rename her the card remains visible.

I did not create the first three characters any differently from the last two
And having the unnamed characters given space on the corkboard but only shown when you click on them seems strange

When the document titles in the Binder are using italic font, it means you are displayed an auto-generated titled based on the available synopsis or text. Once you specify an explicit Binder title, it will also appear as a title inside your Corkboard index card.

Thanks Tiho. Though that still doesn’t explain the weird display properties in the corkboard where a text file that has not been explicitly named is given space on the corkboard but remains invisible until you click on the space it occupies, and then becomes invisible again when you click on the next space.

I’ve also just checked with how 1.9 works and the corkboard simply shows the auto-generated tile as one would expect. No invisibility thing is involved.

No doc should be invisible on the clipboard, I think. Mine, even unnamed, aren’t invisible there. Even tried duplicating some, moving to a new untitled folder. Everything still visible.

I agree, the behavior is a bit strange, and would certainly be in the class of “BUG”.

But it sounds as though your copy of Scrivener has become corrupted in some way, or perhaps your project has become corrupted (an entirely too common experience).

The first could happen because of some random cosmic event, or Windows hiccuping during installation, or a piece of the disk simply goes randomly bad (even SSDs are subject to neutrino events). Not necessarily a bug. But not welcome.

To fix the first possibility, I would reinstall Scrivener completely.
Save your options and themes (in File → Options → Manage [lower left corner]).
Uninstall Scrivener completely.
Reinstall Scrivener in its own directory (do not use a common directory for Scriver 1 and the Beta).
Run it, load your options from the file you made, load the project, and see if the behavior recurs.

To fix the second possibility, create a brand new project, select the entire binder in the suspect project, and drag it into the brand new project file.

I hope one of those helps; because the behavior shown in the screenshots would be utterly annoying.

Thanks rwfranz. Given problems I’m trying to trackdown with photoshop which prevent me either printing to or saving as a PDF file I wasn’t up trying your suggestions. I am trying to write and edit three books, although I certainly appreciate the advice.

As it happen, however, the latest upgrade fixed it and the corkboard is now behaving as expected. That is it displays all text files regardless of whether they have been properly named in the binder. Further, if they aren’t named a blank is displayed in the heading of the note. So all good.

I remained firmly convinced it was a bug, but is no longer.