[BUG] Fullscreen Mode and Scrivener Reboot

OK, so I’ve had this issue since at least 0.23 and it remains after 0.24.

Basically, when I enter fullscreen mode, exit fullscreen mode and then restart Scrivener, the text within the page becomes invisible and the background of the page becomes light orange.

As of yet, the only way to fix/avoid this is by reseting the option settings to default and not using fullscreen mode.

Since I haven’t found a thread discussing this, I would think very few have this issue. Naturally, I decided to see if it was my computer’s issue and installed it on my laptop to check; same problem. One would think this rules out hardware as the cause, so now I am officially dumbfounded as to how to fix this.

I have uploaded a screen to demonstrate the issue. Thanks for your time.

EAsy fix: reset all your colors to default under options. :slight_smile:

I appreciate the reply, mate. And I have done so, unfortunately, this fix lasts only as long as you don’t enter fullscreen mode again.

Look at the last post in the “graphical glitch” discussion. I had almost the same problem, and that worked for me.

I appreciate the help. Unfortunately, again this doesn’t seem to fix the problem.

I’m pretty sure this is what you were saying, but just so I log the report right, you get this happening even when your Options are all set to the factory default settings? And switching to another document and back to refresh it, or closing the project again and reopening, doesn’t fix the problem?

Um. Your half-correct. The page and text will fix, but only as long as I don’t use fullscreen mode again. The moment I enter it, exit and then restart Scrivener, I have to reset the colors to default again.

Okay. I meant after you have

  1. entered full screen
  2. exited full screen
  3. quit and restart
    but before you reset the options, if you switch to another document and switch back, is the text still invisible? Or is it invisible on all documents of the project, not just the one that was in full screen mode? Likewise if you close the project then without resetting the options and reopen, is the text still invisible?

And just to irritatingly ask more questions (;)), do you have to type or do anything in Full Screen to make this happen, or is it enough to load up a project, enter full screen, exit full screen, and close the project–without editing or doing any other messing around in the interface? Since no one else has reported anything like this, all the details you can provide would be helpful!

Sorry for the late response! Alright, I’ve tried everything you’ve requested so let me try to be as comprehensive as possible.

All documents are invisible after restarting Scrivener. I can switch back and forth and nothing happens, still invisible. Switching between projects also has no effect. Interestingly, Scrivener is still functional, you can still type etc, however, no text, cursor, or page is visible.

I don’t have to do anything in fullscreen mode to cause this. A simple ‘double-tap’ on F11 is all I need to set off the bug. It fixes if and only if I click ‘deault’ in the option settings and nothing else (I have tried using default on all the colors individually without any avail).

To reaffirm, I have tried this on separate computer systems and I can replicate the bug. The systems are entirely different. The only similarity I can think of is that they both have ATI graphics cards. I have compiz enabled on both, am running Ubuntu 11.04 x64 Classic and left everything else default.

Great, thank you for the detail! I appreciate the extra work to check all this. I’ll get it on the list and hopefully we’ll be able to track it down.

I can confirm that the same thing happens for me (triggered with F11) with the current version (0.2.4).
In addition to resetting preferences to Defaults, I can also load a saved preferences file to have my text re-appear.

I can confirm the same behavior on my computer.

Since JG reported that loading saved preferences would make text reappear, I tried saving my preferences after the problem appeared. When I loaded them (even after restoring to defaults) the text disappeared again.

Just wanted to point out that, as of beta 025, the bug is still here :frowning:

I will try to see if I can reproduce the bug on Windows as well as on Linux.

Ihave the ‘invisible text’ problem in .25. I set the fullscreen bg to white and lost both the fullscreen and standard text.

Reset everything to default and colors are now ok in fullscreen and standard view.

I have the same problem on the latest beta, reset to defaults solves it…

And it seems to be specific to Linux. I haven’t been able to reproduce it in Windows at all.

Yeah I haven’t had it in windows for a few versions. But to be honest, I don’t use fullscreen mode much. (I maximize it, because I like having a corkboard up while I’m working.)

I don’t use it all on my desktop; but is the only thing I use on my netbook.