Bug: I am now receiving an error about writing to disk, Access Denied

I just updated to version 16 and now I keep having an error message pop up about not being able to save and Access Denied. So, we have a problem now with permissions on the program. I am going to try running the program in administrator mode to see if that stops the error that seems to be tied in with the AutoSave feature. I am hoping Administrator Mode will stop the error as it is annoying. Maybe you need to give directory permissions to the program as part of the installer? I attached the error as a .png. Actually, this is pretty good. I have never had a bug before with Scrivener. With all of the Beta Testing, it is pretty impressive that this is the first time I’ve seen an error pop up. BTW, I have 560 GB of free space on my computer, so it’s not that…

Additional Note: I tried to compile and save PDF and I received a “Could not save file. Access is Denied error.” So, I opened Scrivener in Administrative Mode and I am still getting the same error. It popped up right away. Unfortunately, this makes your program useless as I cannot save any work at all.

Okay, this is what I did to fix issue. I completely uninstalled the Beta version of Scrivener. I even went into the install folder and deleted out any leftover files. I have version 1 of Scrivener, that is untouched. Then I rebooted my computer. Then I right-mouse clicked on the install and installed as Administrator. I changed my directory name to Scrivener3 in the installer. Now Scrivener opens up with the main screen and I selected my existing project to open. No errors. Then I changed my theme to Dark and closed down, re-opened - still no errors. Promising. So maybe there was a dll conflict or something. If anyone else has this problem, this was my solution.

I was consistently receiving the same issue after installing v. I uninstalled/reinstalled as Administrator, then ran Scrivener as per the suggestion above,and promptly received a warning that my anti-virus software (Avast) was blocking Scrivener’s ability to update files.
Once I granted Scrivener permission to alter files in the Scrivener folders on my PC, the error dialog no longer appears and I can work without seeing that pop-up every few minutes.

Probably a permissions issue, but it seems your method worked. Good.