Bug in 1.7.2 with Kaspersky 2015

Found a strange bug. Kind of difficult to explain, but I will try:

I use Scrivener on several machines. Two are Windows 7 64 bit machines which had Scrivener 1.6.1 installed. I updated from Kaspersky 2013 to 2015 on these machines. Scrivener continued to work. Upon updating from 1.6.1 to 1.7.2, Scrivener either fails to open, or opens and immediately crashes and closes, referencing a memory error (Memory cannot be written) Disabling Kaspersky causes Scrivener to open correctly. If protection is re-enabled, Scrivener will continue to open correctly until a reboot. Rolling back to Scrivener 1.6.1, this problem goes away. Or, if I downgrade to Kaspersky 2013, the problem also does not present.

As a side note, both of these machines were updated using the built-in updater. I tried complete uninstalls and there was no change upon reinstall. To throw an additional wrench into things, there are two other machines, one is a Windows 8.1 32-bit tablet with Kaspersky 2015 and Scrivener 1.7.2 both clean installed onto it. The other is a Windows 7 32-bit pc that was recently upgraded to Kaspersky 2015. I updated Scrivener from 1.6.1 by downloading the newest installer on this machine. Neither of these two machines exhibit the problem.

So, I’m not sure if its a Scrivener bug or a Kaspersky bug, or a 64-bit bug…
Might be able to reproduce on a 64-bit system by installing Kaspersky 2015 trial, then installing Scrivener 1.7.2, then attempt to run the program several times in a row. Sometimes the application will open the first time, then fail every other time.

If I can be of further assistance, please let me know.

Probably not useful, but here is the info from Event Viewer:
Faulting application name: Scrivener.exe, version:, time stamp: 0x53b364e8
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x003e0000
Faulting process id: 0x11ac
Faulting application start time: 0x01cfb1336fae554e
Faulting application path: C:\Program Files (x86)\Scrivener\Scrivener.exe
Faulting module path: unknown
Report Id: c233ad50-1d26-11e4-9ca4-005056c00008

Kaspersky Internet Security 2015 is not yet available in the UK. It’s confusing but Kaspersky have a staggered roll-out (which clashes with my normal renewal date, of course).

Kaspersky Internet Security 2014 (UK) works fine in both 32 bit and 64 bit versions of Windows 7 and Scrivener… but I’m not sure if that is of any help. I do anticipate updating to KIS 2015 when available so I’ll watch this thread with interest. :slight_smile:

Thanks for the detailed report. We are investigating the issue, as we’ve seen some similar cases and I’ve reproduced this myself (also on 64-bit Win7). At the moment I don’t have a better solution to offer than just pausing Kaspersky when launching Scrivener the first time after boot up, as you suggested.

I’m aware that BitDefender flags one of the third-party converters that Scrivener uses for import/export, likely because they have the option to hook into the Microsoft Office library to better support DOC, DOCX and PDF conversion, so it’s possible Kasperksy is disgruntled by the same files. These converters were updated from 1.6.1, which fits with the symptoms. The converter files aren’t called until needed, so BitDefender doesn’t typically cause a problem when launching Scrivener, just when trying to compile or otherwise access those libraries, but it’s not clear what’s going on in the background with Kaserpersky that’s triggering the error in this case.

I’ll keep you updated if we get more information on this.

I wanted to take a moment to confirm that the changes made in 1.7.3 have corrected the problem. A big “thank you” to everyone for all for the hard work you have put in to make Scrivener the best writing software out there!

Thanks for the follow-up, and the kind words! It’s good to have confirmation that the changes have worked around the Kasperksy trouble!