BUG. Inconsistent small caps.

Scriv_inconsistent_smallcaps.JPG

I checked the rtf; all it has is an “scaps” tag. No font changes through the line; it’s all designated “small caps.” Seems no reason for Scrivener to display one size and then another.

Bumping this. Capitalized small caps change size with zoom level, while uncapitalized small caps do not.



Same problem here with the last beta.

Yeah. What gets me is that sometimes the font displays correctly, and sometimes it does not. In the example, in the first word, the “lowercase” letters display at about the correct size in smallcaps. The rest of the words are disproportionate. The exceptions to the scaling issue mean there’s some sort of decision being made about which letters to scale, and there seems to be no reason for some words scaling properly and others not.

You would think that scaling fonts would work no matter what the font effect, but evidently not. Not sure why this would change. I’m sure the devs didn’t put into the code any scaling decisions related to text. But why this does this? I’ve no idea. Maybe the QT libs they’re using? But still the behavior doesn’t make any sense.

Still an issue in RC5, including the inconsistency. Yesterday I was thinking “oh, they fixed it”; today, it’s back.

In RC9, I’m noticing it seems to at least be more consistent. Text size is still not right, but it’s consistent, at least for the projects I’ve looked at so far. And if I’ve just opened the file, the text size is even correct. But if I choose a different piece of the project to peruse, the size of lowercase caps changes immediately. It’s close. It’s probably even tolerable, but it’s not correct.

I’m using the Hi-DPI version of RC9 and am experiencing the same problem as before: small caps look fine at 100% but if you zoom in, they stay small while the regular text scales properly

Hm.That part is true, too. However, the size of the (ordinarily lower case) text no longer changes within a given paragraph (which it was doing not too many versions ago).

I’m also seeing this in RC12.

[attachment=0]Small Caps.png[/attachment]