BUG: No Dropdown menu directly after start

After opening Scrivener the Dropdown menus in the toolbar do not work. Instead I get the menu for the click on the Icon instead of the dropdown menu. This gets annoying when I accidentally create empty text files instead of, say, character sheets.

Steps to reproduce:

  1. Close Scrivener.
  2. Open Scrivener (existing project or create a new one)
  3. Click on tiny arrow next to ±Icon (or Layout-Icon or any Icon with a dropdown menu, really)
    Result: The click fires the on-icon-click event (in case of the ±Icon: a new standard text file will be created)
    Expected: Click opens dropdown menu (in case of the ±Icon: dropdown menu to choose from)

After doing this once, sometimes twice, the menus work as expected. This is not a major bug, really, but it gets pretty annoying over time.

Tech details: Scrivener v3.2.3 on macOS 10.15

I can’t reproduce this using the same version setup you are using. Have you tried reinstalling the software yet? That often clears up weird interface issues that can’t be reproduced.

That. Is. Weird. No, I have not reinstalled it yet but I will once I’m back on my computer. Thanks for the reply! Issue is solved then, I guess.

Well hopefully that’s all it takes! But if not we can dig a bit deeper.

Meanwhile, someone just reported an issue regarding this same piece of interface. The observation there however is that tapping on the trackpad is different than “clicking”. Do you use the tap-to-click setting, and if so, would that maybe explain the perceived unreliability?

In fact, I use tap-to-click, but I do not think it’s a related issue, since the problem occurs only once - after the first click the icon-click and the dropdown-arrow-click open different menus, just as intended. If tap and press to click would fire different events, wouldn’t the issue consist over time? But instead the unexpected behavior never returns once I clicked on the button.

Buuuuut I plug in my external mouse and use that next time I open scrivener. I’ll report back if the behavior changes. Also, I can deactivate tap-to-click and check if the issue is gone.
Have not reinstalled yet, though, since work came up and time was scarce.

Thanks for your reply!

Soooo, I can confirm that my issue is solved once I deactivate tap-to-click. Apparently tapping and pressing are two different things.

Thanks for the help, Amber! Great analytical thinking!

Weird! Okay, I’ll mark both of these threads as pertinent. I don’t think tapping should be any different than clicking, but hopefully we can “see” the difference and fix it.

I don’t think a reinstall will fix it, so feel free to skip that unless you wish.

Nah, I’m good. It’s an inconvenience and no game breaker, so I can wait for a fix or the next OS upgrade maybe.

Thanks again!

Another observation: I do not have to deactivate tap-to-click. Pressing the trackpad (you know, actual clicking) does the trick, too, while tap-to-click is active.

1 Like