Bug on footnotes in Quick Reference Panel in a different Mac desktop

I think it’s a new bug (I searched in forum) and a little “strange”.

Writing in Quick Reference Panel / QRP (in Italian: Pannello di riferimento rapido), all is ok in the same Mac Desktop.
Or better:

  • normal text is up-to-date and parallel in QRP and Scrivener. If I write a letter in QRP, the same letter appears in Scrivener; and viceversa.
  • for a footnote in QRP, the same text doesn’t appear in Scrivener. When I leave the footnote, the text in the footnote on QRP is copied in the note of Scrivener (in Scrivener 2, for footnotes, I think it worked as normal text, that is better).

BUT if principal Scrivener is in a Desktop and QRP is in an other Mac Desktop:

  • normal text is up-to-date and parallel in QRP and Scrivener. I write in QRP on Desktop 1, I see the same in Scrivener in Desktop 2.
  • the footnotes not always are up-to-date! (yes, sometimes!). So I wrote a long text in QRP in Desktop 1, I left the note closing QRP, the same text is not copied on the real note in Scrivener. So I lost the text …

If you need information, I’m here.


I’m afraid I cannot reproduce this. Here’s what I tried:

  1. I opened a project, added some text, and created a footnote.

  2. I opened the document as a QR panel.

  3. I hit F3 to open up Mission Control.

  4. I created a new desktop.

  5. I moved the QR panel to the new desktop, so that the main Scrivener window was left on “Desktop 1” and the QR panel was on “Desktop 2”.

  6. In the QR panel on “Desktop 2”, I edited the footnote, adding some text.

  7. With the focus still in the footnote, I closed the QR panel and returned to the main window in “Desktop 1”.

At this point, the text I added to the footnote is all present and correct as expected, with no data loss.

Note, however, that if I had returned to “Desktop 1” without either closing the QR panel or ending editing in the footnote (either by clicking in the main text or hitting Escape), the text would not appear in the footnote in the main window, since editing has not yet been committed. This is expected behaviour and the same as Scrivener 2. Footnotes are like text fields - changes in them are not committed until you end editing.

All the best,

Thanks for your reply.
Yes, I tried this morning to reproduce the strange behaviour but I couldn’t!
I try and try, I hope to find the key to the problem (I’m curios).
Update: found!
During editing a footnote in QRP, without closing the editing, if I edit in principal Scrivener window, the changes are not saved in footnote (the editing still lasts in QRP). If I return to QRP and close the editing, the changes are saved.
BUT if I leave the QRP without closing the editing, and I edit the SAME footnote, problems come. The notes begin to live as independent, like two different entities. So closing the footnote in QRP, all changes are lost.
I hope this can help.

Hi Paolo,

Ah, yes, that would happen and is I’m afraid expected behaviour. Because footnotes are macOS “fields” (like text fields), changes aren’t “committed” until you end editing. So if you edit a footnote in the main editor and don’t end editing and then edit somewhere else too, the version that you end editing for last will be the one that is finally saved.

Thanks and all the best,

Ok, thanks Keith.