[BUG] Random page repositioning

This has been happening since at least the beginning of the year. I didn’t report it because I was sure someone else would. I don’t see a report anywhere.

While editing a document/file, suddenly and unexpectedly, the entire page will reposition. Disorienting to say the least. It happens after I’ve done an edit of some sort, I haven’t been keeping track of what triggers it – I’ve been trying to write, so I’ve been ignoring it.

Today, after a clean install of version 40 on a brand new PC, it happened again in a big way, so I decided to write it up.

I had applied a style mistakenly to 2 paragraphs instead of just the first one I’d intended.

So, I did an undo using CTRL-z to reverse the style application.

The editor repositioned the page to the top of the document.

This happens to be SEVEN PAGES above the spot I’d been working at.

Kinda hard to stay in a writing flow when the editor is all herky-jerky.

Now that I’ve written this up I’ll start keeping track of the specific triggers of this editorial whiplashing.

Additional note: The page repositions when I double-click to highlight a word, hit and miss. Sometimes several times in a row, and other times not. Fortunately it only goes so far as to center the word I double-clicked to the middle of the edit window.

I hadn’t responded to this as I hadn’t been using styles in much of my writing. However, I tested it out with a fairly long document (not 7 pages+, but long enough to test with) and was able to replicate what you were seeing. I used the built-in blockquote style to apply to two paragraphs (at random) in my document. That worked as expected. I then (while the styled paragraphs were still highlighted/selected) did a Ctrl-Z to undo the style. Sure enough, I went back to the beginning of the document. In this particular project, it happens every time I select, apply a style, then do an immediate Ctrl-Z to undo the style.

Edit: Doing Ctrl-Z to undo any style changes will immediately return you to the top of the document. The only way to remove a style change is to turn on invisibles, make the selection to change up to, but not including the following pilcrow, and then selecting the appropriate style. There is definitely something not right with doing style settings and undoing them.

I am not seeing this. A double click selects the word, but I stay exactly where I was.

This happens to me too! I’m so glad I’m not the only one. I thought I was crazy. I thought it was only when I undid things or saved, but it will randomly happen too…dropping down several pages for no apparent reason. I even tried turning off typewriter mode and it still happens.

Just wanted to give an update that it was still happening.

Yep, working dual pane for translations is being a pain because of that.
I use styles in my “translated” pane wich works as intended, but the original text pane ( wich i make no editions whatsoever) changes positions like hell, and all i need this pane to do is to keep track of the position. :neutral_face:

The bug whereby undoing a style application causes the editor to scroll to the top has been filed. Like Jestar, I wasn’t able to reproduce the report of double-clicking to select text causing the editor to scroll, so if you’re able to find a reproducible case (possibly dependent on editor settings such as using a fixed-width editor or enabling–or disabling–Typewriter Mode) and can post those steps, that would be very helpful for the developers to track down the issue.

Reproduction is simple.

Step by step:

  1. Initial state, 2 styles.
  2. Selection of text in “Normal style”
  3. Drag and drop to new location in “Normal style” ( screen shot loses mouse pointer, taken after drag just before drop, see cursor at end of “Paragraph 1 (Normal style)” line.
  4. Document automatically repositioned in editing pane.
  5. Document manually repositioned to where it should have stayed.

[attachment=0]Untitled a.jpg[/attachment]

[attachment=1]Untitled b.jpg[/attachment]

Turns out it’s not just about drag-n-drop, either.

  1. Initial state, cursor at beginning of “Blah 88” line.[attachment=0]Untitled 1.jpg[/attachment][attachment=1]Untitled 2.jpg[/attachment]
  2. Select Format/Table/Table.
  3. Document automatically repositions to line 1.
  4. Configure table.
  5. Manually reposition document to where it should have stayed.

One more.

UNDOING anything done that caused the auto-repositioning will likewise cause auto-repositioning the instant you CTRL-Z.

There might be a problem with styles, too, but for what I’m experiencing, styles are a red herring.

The common denominator here seems to be when paragraph marks are involved.

How to reproduce dual pane text repositioning.

Left pane has the .rtf file from “draft” with some styles, right pane has .txt file from “research” with no style defined.

Actions that changes panes width brings the right pane text back to near the beginning (but not quite)

Actions tested:
Opening the inspector: repositioned
Changing panels width: repositioned
Resizing screen: repositioned
Reopening project: repositioned
Changing right panel zoom: repositioned
Clicking Maximize/Restore: Text stays in place

When opening another “draft” document on the right pane instead of the “research” .txt file there seems to be no errors. Error occurs with typewriter mode on and off.