BUG RC10: Default formatting control: icon bar truncation misses line spacing

Apologies if this has already been reported, but I’ve not seen this one so far. (Please see https://www.literatureandlatte.com/forum/viewtopic.php?f=57&t=63363 for Devin’s original discussion).

There are two bugs with the default formatting controls.

  1. Project Settings > Formatting > Use Current doesn’t have any effect.

  2. Both project settings and Options > Editing > Formatting have a problem when the dialogue is too narrow to show all the icons. When you click on the ‘continuation marker’, you’re supposed to see the list of icons which aren’t visible. This works for the highlight icon, but doesn’t work for the line-spacing control — there’s no indication that such a control exists. Furthermore, if the line spacing icon is the only one missing, then the continuation marker itself is inactive.

[attachment=0]Screenshot 2020-09-29 at 09.01.44.png[/attachment]

Thanks for all the hard work — the beta is looking good and is very impressive.

Hi - Well 1) seems OK. We can test Use Current by changing the typeface to Comic Sans, for example. Use Current will revert it. 2) Yeah, the continuation icon behaviors are not fully developed. For Text Color there’s a working flyout control. For Highlight Color there’s a placeholder. For Line Spacing there’s nought but the inactive continuation icon as an indicator that we can widen the control window for more options. No malfunction, but a placeholder at least would be a helpful, easy fix.

Rgds - Jerome

Hi Jerome

This is odd: it definitely didn’t work this morning (I tested it!). Then when I read your post I went back and tested again, and it worked once. I tested it again and it didn’t work for a couple of times, then suddenly started working again and hasn’t stopped since, over Scrivener and Windows restarts.

I did nothing differently each time (I’ve been using the feature on the Mac for since before official release, so I know how it’s supposed to work — I mess around with paragraph formatting a lot!.., yet for some reason the setting didn’t stick on those occasions. That’s going to be really difficult for the developers to pin down, I know, but it definitely failed for me on those occasions (and for Devin in the original post I linked to). I’ll keep trying to see if I can narrow it down to a set of circumstances which triggers the problem.

Cheers for the confirmation on the other bugs.

Regards,

David.

I will point out that my original report was specifically about the paragraph before/after settings not getting pulled in by the “use current” buttons. Typeface, size, indents, etc. seemed to all work. I don’t know about line spacing since I left that on defaults, but my paragraph spacing of 6pts after was getting ignored when I tried to set the new defaults.