Bug Report - Blacked Out Text[BUG LOGGED]

I’m running Scrivener for Windows beta 3 on Vista.

Opening it today there was something amiss! :wink:

My text was presented in the editor as black text on a black background (should have been a white background). See attached screen shot.

The opening page was the only page displaying this issue. It was resolved by changing the background colour via the editor tool bar.

Steve
11-11-2010 07-33-58 - Scrivener Screen Grab.png

Correction: another page (my doc has five pages) is showing the blacked out text; I hadn’t scrolled down the page sufficiently to see it earlier.

Steve

Steve, which beta version are you running?

I’m running Scrivener for Windows beta 3

Steve

I can also add that this has only happened once, it’s not something that happens every time I open Scrivener.

That makes it worse to track down I know :wink: Sorry!

Steve

Thanks Steve. Keep me posted. I can’t reproduce this, I even tried highlighting in black and then removing highlight, save and close etc.?

I have also had this happen, but have found its just highlighted in black with black text. You can work around it if you set the text to a different color or highlight/change after opening.

I am having a similar issue. My blacked out text came from text I copied and pasted from google docs. In addition to this bug, I am somehow missing or cannot view the “font toolbar” (which I can see in the tutorial version of Scrivener but not in my current project). I also tried to un-highlight the text with no results. Everything is black (text and highlighting) and I cannot find a way to fix it. Please advise.

I just opened Scrivener to this issue as well. I had to go through and turn the highlight off on several pages. I made a backup last time I had opened the file, and I wasn’t having that issue at the time. The next time I opened it several pages were blacked out. I have closed and re opened the file and now they are okay.

It may have been text that I copied from Google documents, it was in a different font than some of the text that was imported from a .rtf.

I’ve not been able to reproduce this despite really trying!

One thing I can add, my text was not pasted in from elsewhere so that’s a bit of a red herring, inviting tho’ it is as a possible route to finding the bug.

Question to the others who have experienced this:

I noticed this issue on two pages in my 5(??) page document, did you see it on more than one page too?

In my case the size/area of the ‘redacted’ text was roughly the same. On the page I took the screen shot from it covered all of the text on that page and this was the page that loaded when I launched Scriv, it was also the the last page that I had worked on. The other page affected had quite a bit more text but only a small part of it was blacked out.

I mention the above because I’m scratching my head, trying to think of way to find common factors to try and squish this bug.

Steve

The blacked out text bug is happening to me as well.

I am using beta 1.3 and I also copied my text from Google Docs (the culprit?).

However, I only encountered the bug when I opened the export zip file that I created in Scrivener on my Vista laptop on my Win7 machine. The text seemed fine on my laptop.

I too have copied my text from Google Docs and had it do the same exact blacked out thing–but I hit “Close Project” from the File menu first. It closed Scrivener altogether and then when I opened it back up, the opening page had blacked out text in a different type font and a different size. Selecting “none” for the highlighting worked to get rid of the black highlighting.

Could it be a font related issue? Most of my text is in veranda 10, but the blacked out part is newly added text in Arial 10? (This just happened to me a second time.)

Strange indeed. I will log and investigate further; however, if anyone can reproduce this reliably and document it that will really help me iron this one out quickly as I’m scratching my head right now. Feel free to email me if you can do this: lee AT literatureandlatte DOT com.

I’ve had a similar issue, which occurs when I paste in text (from Word (yes I still use it), OpenOffice, LibreOffice and Scrivener itself.)
Pasted in text (CTRL-C / CTRL-V) frequently appears in curious fonts (eg MS Shell Dlg 2 ; 8 point)
Highlighting the offending text, then changing to preferred font (in my case Times New Roman 12) often doesn’t work.
Closing Scrivener, then re-opening sometimes reveals blacked-out text. When the black background is removed - presto - I’m in Times Roman.

This is an intermittent problem (the best kind!). But it’s there.
I’m running Scrivener 1.3 on Win XP SR 3

Have fun!

Having the same issue. Blackout on all my pages. I turned the highlight off and it’s fine. Weird, too, because I don’t recall turning the highlight on. I typed directly into Scrivener, am running XP on a computer a few mos old (whatever version that would be), and am using Scrivener v 1.3

I just had the same issue with the blacked out text showing up. I’ve cut and pasted (quick keys) from Google docs as well. It seems like several people have this issue from Gdocs or cutting and pasting across programs.

I’m hoping it goes away but so far closing and opening hasn’t helped. Perhaps after a restart it will clear up. No one’s posted if it disappears after time.

I’m using Beta version 023.

I’ll give this a look tomorrow too, as I’ve had it happen repeatedly with certain documents in the Tutorial, even in beta 023 (on Win 7 64bit). Only recall seeing it in a document that also included other (intentional) highlighting and an inserted image, and the text is accessible if I select it.

I have had similar problems with a text pasted from a website. When pasting the text into Scrivener, it retains the font and font size from the website. I can change the font to the default in my document, but Scrivener stubbornly refuses to change the font size. After a few unsuccessful attempts at adjusting this, it blacked out my text. I had to delete the pasting and try again (unsuccessfully- to change the font size).

So two seperate issues: why is Scrivener refusing to let me change my font size, and why is the text being blacked out when I try repeatedly to change it?

I am using a Vista computer, with files saved on my Dropbox and edited also on a Mac computer.

Hm, the instance I get is in the Tutorial on Step 3: Footer View–text toward the top, just above the yellow highlight, is highlighted in black. It appears this way in 10.rtf in the Scrivener program files for the tutorial, if you open it in another editor, so it’s not just a sporadic thing the way others are talking about, but I wonder if it’s related to either a) the old issue a few betas back where colors went on a value scale and so ended up “blacking out” things (e.g. the annotations were black, footnotes were black, etc) or b) the “viral highlighting” problem where certain invisible characters pick up formatting and won’t let it go, causing adjacent text to pick up the formatting and so on. (For instance, if in the Step 3 document you turn on “show invisibles” and remove all the black highlighting, the surrounding pilcrows retain the highlight, so closing the project and reopening, or even just clicking around in a few other documents in the binder and then back to the Step 3 will cause the paragraph to revert to black highlighting.)

(beta 023, Win7 64bit)