Bug report: failed import of Word documents


I’m evaluating Scrivener for purchase, mostly love it, but am running up against a few difficulties, primarily in importing my existing work. When I attempt to import into my Draft folder the application creates an empty file. During the import the application shows a progress indicator, but the process stops abruptly (e.g., at 2% for one of my files).

I’ve tried to narrow down the problem, but it is not consistently reproducible: the same file and same steps sometimes fail like that and sometimes succeed. I think that it might have something to do with images in tables, but it’s hard be certain.

I have a sample document that fails to import about a third of the times I try. Steps to reproduce:

  1. Create new Blank project
  2. Select the Draft folder
  3. Ctrl-shift-j (or use menu)
  4. Choose the sample document
  5. At this point, either the document imports (without images) or the progress indicator appears and then the import fails.
    (Unfortunately, the forum will not allow me to post docx or rtf files. Available on request.)

I’ve tried to work around the problem by exporting from Word to RTF, and then importing the RTF into Scrivener. This more consistently produces bad results, but in this case Scrivener outright mangles the tables. I’ve attached screenshots.

I’m using Scrivener for Windows version, Windows 8, Word 15.0.4505.1510 (Microsoft Office Professional Plus 2013)

scriv bug 1 - RTF.PNG

Scrivener doesn’t have Word’s table-layout abilities, so except for simple tables, you’re usually going to find that tables won’t appear the same. For the most part you’ll want to work the other direction, just sketching out the table in Scrivener and then polishing it in Word after compile. RTF import is usually best (it sounds like you were using DOCX to start?) but you could try enabling the MS Word converters from the Import/Export tab of Tools > Options if you haven’t already; that might improve the quality of your .doc/.docx imports. At the moment images do end up stripped from the .docx import, even with the alternative converters enabled, so you may end up needing to resave to another format either way.

Thanks for the response!

Sorry, yes, I should have specified that I’m starting with docx files. I tried importing them directly, and also tried going through RTF as an intermediate format.

I’m fine with losing images at import–adding them post-compile instead seems reasonable. I also don’t care about the formatting of the tables after import–I just need the content to import and for the compiled results to be tabular. Unfortunately, I have entirely too much data in tables to re-enter it cell by cell, so the import is pretty important.

I wasn’t aware of the MS Word importers, so I’ll give that a try. Might be what I need!

Unfortunately, even with that option the import failed. Still, thank you anyway for the tip–I appreciate it!