Bug + script settings + dialogue "center"

I would like to know if anyone is able to set their “Dialogue” to “center?”

  1. Format
  2. Screenwriting
  3. Script Settings
  4. Dialogue
  5. Paragraph
  6. Alignment
  7. Center
  8. OK
  9. ERROR - this setting does not stay.

I have copied the settings from “Scene Heading” (Alignment-left, spacing-1.0x 24.00, Left indent-.50, Right indent-6.50, first line indent-.50, first tab-0.00, spacing before-24.00) and changed the Alignment to “Center.” When I click on the footbar “Dialogue” it returns to “left.” After re-opening the scripts settings dialogue it has defaulted to “left.”
I’ve tried changing all the settings to “0.00 Center” and still get the same result.
I have been able to change alignment on “Scene Heading” to “justify” but again when I try “center” it defaults to “left.”

Script settings aren’t correctly saving the centred alignment; this is a bug and I’ve reported it for the developer. Sorry for the inconvenience!

Thank you for getting back to me. I thought maybe I was going crazy! :slight_smile:


I saw this in the latest release notes: “Fixed a script settings bug preventing elements from saving with centred alignment”

I appear to be having a similar problem in Novel compile (with minor alterations). I have titles at the top of my text files (chapters) and they are centered according to my formatting. When I compile, they left justify. I have the work typed in Courier New, as RTF. If I save “as is” I get them centered but also get very inconsistent paragraph formats from file to file. Some fit the page, some wander off into screen hinterlands. When I come back to my Scrivener project after compiling, many (but not all) of the titles I have centered, have lost their formatting and are left aligned.

Is there a way I’m supposed to be using the Binder titles as chapter titles? What am I doing wrong?
BAH! Never mind. I think I found my answer. Doesn’t change the above glitch but I found the bit about using Binder titles for Chapter titles.

Carry on. Nothing to see here.

Thank you,

I think I may have a related problem, and if it is a bug, then I can stop driving myself crazy about it.

I’m trying to set up a format for a script paragraph which does this:

Setting:(A loooooong tab space before…) A multi-line description of the setting.

So I set the left indent for the paragraph and first line at 3.5 inches, and the first tab at the same place.

But when I invoke the paragraph type I get everything but the first tab. It just isn’t there. I can add it manually, but that reverts the type to general text.

So having seen this thread, it looks very similar to the “centered” thing–that is, something may also be keeping the first tab setting from registering.

If so, please confirm so I can stop tearing my hair out. :confused: If not, what am I doing wrong?