[Bug] Scrivener crashes when dragging 2 documents

If I select 2 documents, drag them (but do not drop them) and wait for a while, Scrivener crashes with the following error message:

QFile::copy: Empty or null file name QFile::copy: Empty or null file name xdndHandleBadwindow returned true Segmentation fault (core dumped)
You may have to keep the mouse pointer over one of the dragged documents (so that the mouse pointer turns into an icon signaling that the files cannot be dropped at that location).

There seems to be some kind of timeout that kicks in. If I drop the documents earlier Scrivener wont crash.

This is on a 64-bit, Ubuntu 12.04. Scrivener version

I tried with and without --style=CleanLooks … but got the same result both times.

I also have an error message when starting Scrivener on the command line but I don’t think it’s related:

p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory

Can anyone else reproduce this? How about on Windows or Mac?

It’s no problem when dragging 1 document, only two (or more).