BUG? Section Layouts do NOT create Page Breaks when compiled!

Or did I reset something wrong somewhere?

And while we’re at it,

When filing a bug report it is a good idea to provide as much information as possible, including every step you take in changing various settings. It is also often very helpful to try and demonstrate the problem from a clean test project, like one of the template starters or even Blank, showing each step required along the way. If you can’t actually do that, then it serves as an illustration for why we need more contextual information.

Page breaks work fine, normally, so we can’t really even start troubleshooting with a report that states they don’t ever work. To provide an example of the level of detail required, here is a working case:

  1. Use File ▸ New Project... and select the “Blank” starter, creating a test throwaway project anywhere you like.
  2. Type “Page <$p>” into the starter document. (This will print the current page number.)
  3. Click into the binder, and with the starter document selected, use Documents ▸ Duplicate ▸ without Subdocuments.
  4. Use the File ▸ Compile... menu command.
  5. Change the Compile for setting to “Rich Text (.rtf)” at the top.
  6. Click the Assign Section Layouts button, and assign the “Section” type to use the “New Page” layout, which generates a page break and prints the text verbatim.
  7. Save these settings, and then click the Compile button, saving the .rtf file somewhere convenient.
  8. Open the RTF file in a word processor that is capable of showing page layout, such as LibreOffice or Word.

You should see two separate pages, each numbered correctly both in the text content where we added a page numbering token, and in the footer area where this is done by the compile Format (Default).

1 Like

I don’t quite follow you, AmberV. Did you skip a step 3a, like " write some material" or “import a portion of your project” after “duplicate without sub-documents,” which doesn’t offer me any content?

Step (2) is where you would type a little content into the starter document, using a special placeholder that prints the page number. So when you duplicate, you should end up with two documents that have the same text in it.

I’ve tried importing a scriv test project that I created for this purpose. It appears at the bottom as you know, of the binder. Am I supposed to then move the research and trash folders to trash? (I found the same issue very confusing when I imported my main project, created in Scriv1).

Importing a project copies all of its binder items into a subfolder, including the Draft, Research and Trash folders. In most cases you would want to move the contents of those folders into the proper folders (with the special icons) in the project you imported to. As for the trash folder and its contents, it’s up to you whether to keep that or just trash the whole thing.

OK, I think I got it, altho I was unable to make the duplication work. Part of my confusion is that I simply did NOT understand the purpose of the other Section Layouts–that they should be used ONLY as an ALTERNATIVE to formatting within the Editor.
It’s also very confusing that you have TWO ‘Options’ tabs in the Compile Overview pane–1 under the Formats (L) column, 1 above the Compile (R) column.

Finally, AmberV, can you please help me with a composition/editing problem? My document has both footnote and endnotes streams.
(I used the endnotes format to anchor the “commentary” or context info to the appropriate place in the text during composition.) Now I want to convert the endnotes to an essay-type format, either at the end of each relevant chapter, or, alternatively at the end of the entire narrative. Is there some way to rework the contents of the endnotes into a normal paragraphed essay, stripping out the numbering to avoid cluttering up the mss, short of “new section/cut and paste”?

OK, I think I got it, altho I was unable to make the duplication work.

Well, you could always just create a few items and type stuff into them, too. I don’t know why it wouldn’t duplicate an item though. With the way we set things up, each file in the binder goes into its own page break section. How we get to the point of having two or three to test with is immaterial.

Part of my confusion is that I simply did NOT understand the purpose of the other Section Layouts–that they should be used ONLY as an ALTERNATIVE to formatting within the Editor.

I wouldn’t put it that way. What might not have been noticed is that its the page break indicator on the Layout preview tile that gives you a page break. All that really means is that the layout has been set to insert a page break. Any layout can set a page break before it, including those that change the formatting.

Select the “Manuscript (Times)” Format in the left sidebar for instance, click the “Assign…” button, and scroll through the options. You’ll see a good number of them include a page break, along with other possibilities like headings, and conforming the text formatting to manuscript standards.

And if you see a Layout you want to use that doesn’t have a page break, just do this:

  1. Double-click on the layout tile to edit it.
  2. Select the Separators pane.
  3. Disable the default separators checkbox at the top if necessary.
  4. Set the Separator before sections dropdown to “Page Break”.

It’s also very confusing that you have TWO ‘Options’ tabs in the Compile Overview pane–1 under the Formats (L) column, 1 above the Compile (R) column.

Sorry, I don’t know what you mean by that. There is only one Options tab on the right side. There are no tabs on the left side.

Finally, AmberV, can you please help me with a composition/editing problem? My document has both footnote and endnotes streams.

Whether to use footnotes, endnotes or both are settings in the aforementioned Options tab, toward the top, so long as the type of file you are compiling supports the notion of having two different kinds of notes. Beyond that, it would probably be best to search the forum for existing discussions on that, as I’m sure there are some on that matter.

Fortunately, that is impossible.

Well, there are two cog-wheel icons. One of them has the tooltip “Options”. The other are options the manage the Compile Formats.

Ah, I see what could be meant by that statement then. I think that is more of an icon problem though, it really should be one of those ∙∙∙ buttons, which indicates additional commands relevant to the pane, which often just duplicate the right-click functions for accessibility.

Yes, I’d noticed the cog-wheel and ellipsis menus are used inconsistently. I have no list of where that is the case,though.

I’m just suggesting that this needs to be highlighted in the Manual and Tutorials.

Could you point me to where the documentation refers to compile options without pointing out where they are in the vicinity, or without at least cross-reference to the section where it is pointed out (along with a screenshot showing the tab bar)? I’m always happy to fix anything that isn’t clear.

The way I have it currently is that §23.4, Compile Settings, begins with the statement that they are all located on the right-hand side of compile overview, organised into tabs (which it then goes on to enumerate). §23.4.3, General Options, is where you’ll find the screenshot of the tab, and a complete description of all the various options found within it.

(Note: in §23.2.5, where you will find the utility button in the Format sidebar discussed, it does refer to this as a ∙∙∙ button—as this and a few other spots are already written up as needing revision.)

Below are Compile Overview screenshots for Mac and Windows. On the Mac, one of the “options” icons is ..., not a gear. To me, the gear means “settings”. Maybe the difference is a Windows/Mac thing.

Nevertheless, if you wonder what an icon is doing, all you have to do is click on it and find out.

yes, assuming the first of your images is Windows, it does seem to be a Mac vs OS problem.

I don’t think two gear icons in a dialog lives up to the word problem, but it is a Mac vs Windows difference at this time.