Bug: Text shifts up and down when adding text at top of document

When editing a document (e.g. a single scene in my novel), the document is larger than the text editor’s window (the scroll bar has appeared), and I’m adding a new text at the very top–the view in the editor jumps up and down as I type.

I’m using v3.3.1 (15588), on MacOS Monterey v12.6.7, running on a MacBook Air M1 2020. In my document I’m using a named style with a specific font, about a 1.8x line spacing, a maximum line length, and first line indent.

The bug exists whenever I add text to the very first line of my document. I can type a word without issue, but when I type a space, the text jumps up one line to push what I was typing out of view. (It’s possible to scroll the window to see my new line.) However if I ignore the problem and type the first letter of the next word, the text jumps back down so the first line is again visible. And so it goes… While typing that first line the view jumps up and down. As soon as I get to the end of the first line and typing wraps to the second line, the view stops jumping. I can insert text anywhere near the top of the document without issue, except for the first line.

A related issue is that when editing near the top of a longer document, the view shifts up slightly, to cover the white space above the first line. This is probably a feature, but I wonder if it’s related to the bug. This is not my favorite feature, I want the view to stay where I put it as long as I don’t type off the bottom of the editor’s window–but I can see it might be handy for someone with a tiny screen.

The workaround is to add a fake first line, then take it out later. But a bug’s a bug. Squash this one, please. Thanks a million.

Hi Scotty. If you go to View > Text Editing and enable the Typewriter Scrolling setting, does that have any effect on the two issues you’re noting here?

Looks like a missed an important detail when describing the issue: I’m in ordinary application view with the binder, inspector, and toolbars. After some experimentation I discovered typewriter scrolling is only available in Composition Mode. Bummer, typewriter scrolling works brilliantly.

Hi Scotty. As per §16.3 of the manual, typewriter scrolling should be available in Scrivener’s main editor if you enable the View > Text Editing > Typewriter Scrolling command. Its keyboard shortcut is Shift+Cmd+T.

You might need to go to Scrivener > Preferences > Editing and adjust the dropdown next to “Typewriter scroll line” to get the setting in the correct part of your Mac’s screen.

Does that resolve the issue?

I’ve been experimenting. BTW, I don’t have page view on. The editor window presents the document as if it were one long scroll.

Being in Scrivenings Mode (when I start at the containing folder) works 100% of the time. And it mostly works when I start at the target document. “Mostly works” means I still get a little offset at the top of the file when clicking between files, but the offset goes away if I type on the top line, and doesn’t jump as I type. But it’s not consistent.

My girlfriend wanted to discuss the setting of her next novel, so I minimized Scrivener and we explored Colorado lakes while panning and zooming in Google Maps using Firefox. Discussion over I minimized Firefox and brought Scrivener to the front to continue my testing.

Weirdly, the jumping had fixed itself, even with Scrivenings Mode off. I double checked. Then the jumping came back with a vengeance, as even Scrivenings Mode couldn’t keep it away. Horrors! This bug had been 100% reproducible. After a bit of turning features on and off, the bug settled down to its normal bugginess.


I suspected all the stuff (toolbars and whatnot) at the top of the editing window was to blame. Here’s what I have turned on and where I found the control:

  • Format Bar – View >> Text Editing >> Show/Hide Format Bar
  • Header – View >> Editor Layout >> Show/Hide Header View
  • Ruler – View >> Text Editing >> Show/Hide Ruler

Trying a bunch of combinations of this on or that off, jumping comes and goes (seemingly at random). However, the offset bug is tied to the ruler. And if the offset bug is gone the window never jumps. In other words, the two bugs seem to be linked.

A better description of how to view the offset bug: Create several text files and fill them with text so that the scroll bar is visible in each. Set the cursor at the top of each file.

  • Ruler OFF - Selecting files from the binder will show about half-an-inch of white space at the top of each file. Beginning to type on the first line has no effect. The file does not “auto-scroll” until you type off the bottom of the window.
  • Ruler ON - Selecting files from the binder will show minimal white space at the top of each file. Typing on the first line will cause the text to scroll a bit so that full half-inch of white space is visible. Jumping happens when typing a space, AND there’s stuff (toolbars and headers) above the Ruler. Type anywhere else in the file and you get the expected behavior of no “auto-scroll” until you type off the bottom of the window.

The real work around is to turn off the Ruler–for now. I like it, but it’s not important until I want to create a new paragraph style. The Header isn’t important unless I want to split my window, which is rare (I use the Binder for navigation). And the Toolbar is critical–it must be on.


Ruth, in normal view Typewriter Scrolling is grayed out. I’ll follow your instructions and see if I can get it to work. I usually put a few blank lines at the bottom of a file so I’m not typing at the very bottom of the window, then remove them when done.

Thanks a million.

Make sure that you have the cursor in an Editor window and are not in Page View mode when you look at the menu. I just checked, and with those conditions Typewriter Scrolling is fine on my system.

1 Like

Oh wow. That worked.

As an aside, not sure why the cursor needs to be in the editor window and not somewhere else. The settings are for the editor window, so there should be no confusion as which window I’m setting Typewriter Scrolling for.

Meanwhile, the offset/jumping bug still exists. Has anyone tried to reproduce it?

Hi Scotty. Yes, I tried to reproduce your original report on my Mac. But, I wasn’t encountering the same jumping issues you’ve experienced. Even when turning off typewriter scrolling.

Have you tested a second project like the Interactive Tutorial to see if it has the same behaviors?

I’d like to know if multiple projects are able to reproduce the issue on your system.

It’s possible to split the Editor and set Typewriter Scrolling for the two panes independently.

It’s also not possible to set Typewriter Scrolling in Page View, in the Outliner, or in the Corkboard. Probably the setting being unavailable when it doesn’t apply is to keep people from enabling it, being confused when nothing happens, and then being confused again when they switch to the Editor and suddenly it works. Disabling inapplicable settings is a pretty common software behavior.