[Bug] Writing mode (F11) unreadable

Switching to writing mode by hitting F11 used to get you black text on a light grey background. Now it’s black text on dark grey, which is virtually unreadable.

Have you changed themes recently? That might have caused it.

You can go into preferences and set your full screen fonts and backgrounds to whatever you like.

No, I’m quite conservative with these things. Didn’t even know there were themes to choose from. :laughing:

I’ve done some testing in the meantime, maybe it helps (and someone can confirm this):

  • I use highlighting a lot. On a page with highlighted (e.g. color background) text, the writing is black against whatever color I choose for highlighting. If there is text without highlighting on the same page, it is black against dark grey.
  • On a page with no highlighting at all, it is white text against dark grey.

To me this seems like there’s supposed to be some auto-recognition in place, but it doesn’t do it properly.

Go to File > Options > Appearance > Colors > Composition Mode.

This is where you set pretty much everything having to do with Comp Mode. colors. Do the settings match what you’re seeing?

  1. If the settings changed on their own, then I’d call it a bug. Unless, as mentioned, you’ve recently changed Themes OR have recently restored Options via Load Options from File.

  2. If the settings don’t match what you’re seeing in the program, then I’d also call it a bug.

By the way, just as a data point, I haven’t experienced either of the above. Things related to Appearance have been rock solid for me.


Jim, I appreciate your trying to help, but it also appears like you are ignoring information I have already given.

Like I said, for regular text I sometimes get white against dark background and sometimes black against a dark background, depending on the “circumstances”. Now if there is not even a setting to justify (let alone change) this type of relativity, how can it not be a bug?

You are correct. Trying a ‘drive by’ assist was a mistake on my part. :blush:

Select all you text and remove the text color, as sometimes the text is set to have black color, which is not readable on black background.

Thanks, that did it for me. 8)

For the record: In my humble opinion, using a dark background in composition mode is special interest and not suitable as a default setting. Because now, after fixing this issue, ALL text is whiteish (or is this light blue?), including the text in the highlighted sections (and a light text against yellow or bright green is about as hard to read as a black text against a dark grey background). In other words, this will work out of the box for some, but create substantial problems (read: posts like this one) for others. Now that I know what’s going on, I will be able to configure everything on my various machines to mirror Scrivener 1 settings, but maybe it would be better to save others from running into the same issues.