Bugs in Scrivener 1.2.5 Linux

I’ve been using Scrivener for a couple of hours now and noticed the following bugs:

  • The menu item “Edit -> Character Map…” doesn’t do anything

  • The menu item “Tools -> Spelling” opens a new window “Spelling” but it’s dead. I also don’t get wavy red lines as I type even though “Check spelling as you type” is enabled.

  • Huge monospaced font in the Synopsis. It can be changed with one of the Fonts settings in the Options dialog but it’s not clear which one.

  • In the console, I see this error message several times: sql error adding document “cannot start a transaction within a transaction Unable to begin transaction” 314

  • I’m missing an English dictionary in the download list. It’s also no available in the “Select…” dialog that I get when I click on the button in the Spelling options.

  • Downloading the German dictionary downloads something from literatureandlatte.com but after a restart, the list of dictionaries is still empty.

Regards,

Aaron

Never has done anything. Workaround is, simply, use the system character map accessory

Have you installed aspell and libaspell-dev, as well as the multiarch libraries? You’ll need to uninstall Scrivener first, then re-install it after. Still doesn’t work well, though.

It’s found under Options → Appearance → (Fonts) → Cork Board → Index text

It isn’t in the download list in the windows version either, I suspect because it’s there by default.

Are you on a 64-bit system? RobHamm had some steps to get spellcheck working on a 64-bit system. (Jinx magicfingers. :wink: )

:stuck_out_tongue:

Please remove the menu item from the resource file. It’s confusing to have menu items that don’t do anything. Creating the menu item again when the functionality is implemented will need only a few minutes.

I didn’t have aspell installed.

Since I’m just unpacking a .tar.gz, I’m not sure what reinstalling is supposed to achieve but I did it anyway → no success. Spell checking is as dead as always.

This is a place where better error messages or some logging would really help.

Okay. An option in the popup/context menu of the UI element would work better.

So why isn’t it in the list, then?

Digulla, I’m sure that the developers will find your feedback enlightening. You seem to have a lot of insight into how things should be done. As for me, I’m just another enthusiast. If anything I said helped you in any way, then I’m glad. I’m sorry that I couldn’t be more helpful; perhaps others can help you more.

Your experience at this point in the Beta cycle with Linux will be very different depending on your processor architecture and distribution. Many things are known to work fine; other things don’t. Give yourself time to get acquainted with some of the older threads on this forum, and I’m sure you’ll find much to help you get up to speed. Have you, for instance, tried running Scrivener under wine? I’ve had the best success running it under PlayOnLinux, which allows you to test using different wine versions.

As of this beta I’m so pleased with how it’s working that I’m not running my windows VM anymore, other than to do some deep spell-checking from time to time (it mostly works for me, as I mentioned more than once.) I wish, for instance, that the MMD stuff really worked, but that’s okay. I can export to text, and I’ve developed my own MMD -> epub & mobi compiler, so I’m cool with that.

Oh yeah, I forgot to mention. I’m a retired teacher who writes full-time now. I literally could not do anything without Scrivener. I’ve got novels to finish!

The point I’m trying to make is that there is a lot that works well, especially for an unsupported project. Sometimes the ride is bumpy; that comes with the whole “beta” thing, right?

Cheers!

Maybe there is a misunderstanding here. I understand “beta” as “we want feedback” so I report any bugs/issues/oddities that I find. That’s what I did. That doesn’t mean I dislike or hate Scrivener.

Of course, I’d prefer a real bug tracker where I could see whether my work actually achieves anything - forums are kind of “black holes” in this regard. Your comment “search the forum for old threads” is just just such a symptom: The same old bugs get reported over and over again since there is no good place to find them, developers miss them because they are not visible, new users stumble over the same issues again, wasting everyone’s time :slight_smile:

Regards,

A. Digulla

No misunderstanding–I couldn’t agree with you more!

Cheers!

I am also having issues with spell check.

I am running Fedora 17 with Gnome3. I ran an update within the last 24 hours (and usually do it once a day). Other system specs of (or not of) not: Intel I3, 8gb ram, thinkpad laptop.

Similar to our friend digulla, I only extract the tar file. (I also copy the contents to /usr/local/LiteratureAndLatte/bin/Scrivener/)

I do not follow the part where magicfingers says to uninstall Scrivener. A while ago I fought with this for a while trying to get it working, and I think i have aspell and libaspell-dev installed.

Suggestions?

If you’re just using the tarball then obviously the uninstall doesn’t apply since no “installation” has occurred. But you need to install the 32bit versions of these libraries if you’re running a 64-bit OS. I assume that you already know that. There was a suggestion in one of the posts about this that the order of installation might matter; the thread is here: [url]Linux user thread - #171 by randywallace]. You might look through this to see what you can learn from it; at the very least, you will see that this is a long-standing issue.

One used to be able to use getlibs. There’s an issue with multiarch libraries and the Scrivener beta that as far as I know doesn’t have a full resolution yet. Installing the multiarch libraries doesn’t appear to solve the problem.

Clearly a real solution will depend on L&L building a 64-bit version of Scrivener. I think it’s safe to presume at this point that Lee is aware of the problem.