Bugs when updating projects to v3

Scrivener is my favorite writing software, and maybe my favorite software package period. So I was excited to hear about the new version. When I installed it yesterday, however, I found that I needed to update v2 projects to work with v3. Fine, that’s fine. But I have had numerous problems doing so.

  1. v2 files apparently have permissions problems that results in needed recovery of files during the upgrade.
  2. This creates a backup version of the file in my Dropbox folder where the files live.
  3. After recovering and updating, the project does not show–it loads in the background. If I command-tilde, it does not toggle to the project. If I click on Window, there is a check next to the file. If I then scroll down to the checked file, it finally shows on my monitor.
  4. Every time I quit the upgraded project (with recovered files) it creates yet another backup file of the project in the same Dropbox folder.
  5. I tried to run disk utility on High Sierra, but it crashes and requires a hard reboot. This happened several times. I booted into recovery mode and it showed the disk is fine.
    Any thoughts?

A) This part sounds like you may be having some trouble that is unrelated to Scrivener.

B) Scriv’s producing a safety backup copy of your project before updating it is not happening because of the file recovery. It does this as a safety for you – leaves a copy of your v2 project untouched. So, the one marked as Backup that it makes is just your original v2 project. This special safety Backup is not to be confused with your regular backups Scriv generates by default on close.

C) But when you close the project, if Scriv is generating a backup project into that Dropbox folder, then it sounds like your Scriv 3 is set to backup your projects to the very same Dropbox folder where your project originals are. That is a bad idea. You should check your Scriv3 preference to determine where your backups are going and point it to somewhere else.

D) However that may be, until someone with more expertise comes along: What happens when you try to open/update a project that is not inside your Dropbox folder? Same result?


p.s. BTW, that file recovery process is not itself a bug – but a way the program detects and corrects for possible corruption in your project files. I have seen that message before, but I would certainly not expect to see it on every project I updated!

You solved it. The backup files in v3 go into the same folder (by default). I moved them into a backups folder and all is well now. I misunderstood what was happening. Thanks!

Glad you got it sorted. Happy sailing.