Can I switch off 'this word may not agree with the rest of the sentence'?

Scrivener’s spellcheck has taken to informing me that ‘this word may not agree with the rest of the sentence.’ Latest example: in the sentence ‘I met their king’, it wants me to substitute ‘there’ or ‘they’re’, both of which are obviously wrong. Indeed, it hasn’t once intervened correctly.

This keeps happening and is quite a timewaster. How can I switch it off? (Or will Scriv only be happy if I take on all its suggestions and write ‘They’re meeting their king there’?)

FWIW I do not have ‘check grammar’ selected and can’t find anything that seems to refer to this in Preferences.

It sounds like you’re looking for this thread. In short though, it is good to remember that there is no such thing as spell check in Scrivener. You are looking at the same thing that underlines words in Safari, Mail, and so on. This is really a Mac question.

I agree with you, I don’t think I have encountered a single occasion where this dumb thing correctly spotted a flaw in my writing. That in and of itself is probably lowering the quality of text around the world, because not everyone knows when to use these different words properly and might trust the machine, following it’s advice to there detriment. (Note: Apple has no problem with that sentence. :laughing:)


Think of it as an advantage. If you can outthink Apple’s woeful spellcheck/grammar checker and others can’t and drink the Apple Kool-Aid, your novel will be better than those people’s novels.