can you compile one chapter only

Is there a way to compile content from a folder into one file? my goal is to share one chapter with an editor.

Sure. You can tell the compiler what it should compile. PDF attached has the details (for S3).

Compile.pdf (269 KB)

Definitely. In the Compile dialog, you can simply choose what to include in your compile – in various ways. Look at the right hand pane of the three panes of the compile dialog. You can manually choose, or you can specify that you just want to compile the stuff that is currently selected in the Binder – perhaps the simplest way to do what you are wanting to do.

-gr

Thank you friendlies.

Unfortunately, each and every time I attempt a compile, the program hangs / doesn’t respond.

Sorry to hear you are having trouble – that definitely shoukdn’t be happening. You should contact the equally friendly people at LitLat support.

gr

Try the checkbox: “Treat compile group as complete manuscript” in the compile dialog (note in V2 it was in a drop down, not a checkbox).

In V2 I could never compile just a folder without having that option turned on, the program would hang and eventually crash. I haven’t yet tested whether the same holds true in V3, but it might be worth a try.

What format are you compiling to?

Do you get an error message at all?

Can you compile to any other format at all?

Which version of Scrivener are you using?

Do other Scrivener projects compile?

Thank you, All.

-I’m using V 2.8 for Mac.
-Don’t really have any other projects to compile.

  • No error - spinning wheel that never resolves.
  • Exporting to MS Word.
  • When I check treat as complete draft, same issue occurs

Hi

Attached is a sample S2.8 project that does compile to MS Word. Would you like to try compiling this file on your Mac? If it works, we will know that compile is functioning properly, and we can then try to identify if there is a project-specific or setting-specific reason for your own project refusing to compile.

In your post above, you mention both compile and export. Neither method works?

As another test, will your project compile to RTF or PDF?

TestMSWord.zip (33.3 KB)

EDIT: In the thread below, one of the mods/developers suggests checking import/export settings. Might be worth reviewing on your installation of Scrivener.

https://forum.literatureandlatte.com/t/compile-not-working/32066/2

Thank you, Bridey.

Using the test file you provided, I was able to compile to several different file types. It worked smoothly no issues.

I also unsuccessfully attempted to compile again with my own file - with modified java settings as described in a forum post you pointed me to.

That would suggest there is an issue that is specific to your project. Does it contain images? Any extended unicode characters? Any text that was pasted from another program, complete with inherited formatting?

In the post below, one of the devs suggests doing partial compiles to identify if there is an errant file. I know you are compiling one folder at the moment, but have you tried compiling a single file in that folder?

https://forum.literatureandlatte.com/t/pdf-stopped-compiling-for-scrivener-project-file/30527/2

You could obfuscate your project (by duplicating it and then searching for all the letter As and replacing them with Xs, then the Es, Is, Ts, etc until the text is rendered meaningless with countless Xs) and share the obfuscated copy here. Someone might then be able to download the copy and identify the issue for you. Remove any personal metadata or front-matter contact info.

I found a solution that allowed me to compile my project. It looks like several images that were imported into the project might have been the culprit preventing me from compiling the project.

Scrivener Support shared the following with me.

“It is strange that an image should turn out to be the culprit, as that didn’t impact things either when we tried compiling it, or when you compiled things in the other account. So it looks like there is still a problem with that specific account on your system, and whatever it is affects the file converter when it is processing images.”

Thank you all for helping me trouble shoot this challenge.