Cannot apply Inspector settings multiple index cards[NOTED]

Procedure:

  1. Selected multiple index cards simultaneously on the corkboard.
  2. Uncheck “Included in Draft” in the Inspector.

Issue:

The new draft inclusion setting is applied only to the index card which was last clicked on, not to all selected cards.

The inspector panel should hide in this scenario to prevent multiple updates.