Cannot create a new project, get error message

I’m using OS X 10.10 Yosemite
Whenever I try to create a new project no matter which folder I try to use, a new one or old one, the app keeps trying to save it in another folder with a 6 month project. Then it says I don’t have space or permission to do it. I have 400GB of space and never restrict permissions on my docs. I checked those two. This folder has a project that has been open continuously for about 6 months which I just closed to start another long project. I have tried moving the app to the trash and reinstalling but the same error message pops up. What should I do?

This is error message

The project could not be created at ‘/Users/Andykwong/Documents/Writing/Year of My Awakening/Untitled.scriv’.

Below that it says I don’t space or permissions

This part of your description is unfamiliar to me. Could you describe precisely what steps you are taking, and what is happening as a result for each step?

Also, try with the stock “Blank” template as well. Sometimes problems can arise from trying to use starter templates, and we might as well get those problems out of the way. Blank is produced straight out of the software from scratch, bypassing any potential issues with decompressing and extracting a starter project from a template.