Cannot create new project

I am trying to demo this software, but when I click to create a new project and enter a project name, it just sits with a spinner and never creates the project.

I apologize if I missed something - I did look to see if someone else has been having this problem, but I couldn’t find anything.

This is on a Macbook Pro running OSX Lion.

Hi,

Thanks for trying Scrivener (or trying to try it). I’ve never heard of this happening before. Have you tried creating a project from the “Blank” template? If not, could you try doing so, please? The reason I’m asking you to try that is because the “Blank” template creates a new file from nothing; all of the other templates unzip some data. My first thought is that it could be a problem with the Mac’s internal zip utility on your machine, so if we can narrow it down, we can troubleshoot from there.

Thanks,
Keith

Thanks for responding so quickly, Keith. The software did indeed allow me to create a blank template without issue.

Any input on next steps would be most appreciated. In the meantime, I’ll try to look into it on my own as well.

Thanks,

Jim

Okay, that’s partially good news, but it does suggest that there is a problem with your machine’s internal unzip utility. Next steps:

  1. Open up Console.app from /Applications/Utilities and have it alongside Scrivener as you try to create a project from one of the templates (not the Blank template). Does Console report any errors when you do so?

  2. Find a zip file or create a zip file by ctrl-clicking on any file in the Finder and selecting “Compress ‘filename’”. Then, open up Terminal.app from /Applications/Utilities and type:

cd path/to/folder/containing/file

Eg. If your .zip file is in the ~/Documents directory, type:

cd ~/Documents

Then hit enter.

Then type:

unzip filename.zip

(Substituting the correct file name, of course.)
And hit enter.

What happens? This is the unzip utility that Scrivener uses, so if this hangs or throws an error, we know this is the problem; if it shows any particular information, that may be helpful too.

One other thing, too - try using File > Back Up > Back Up To and tick the option to back up as a ZIP file. Does that freeze too? (That uses the zip utility - I’m trying to determine if it is both the zip and unzip utilities that are having problems.)

All the best,
Keith

Yes, it does report an error (included below). Also, I tried to follow your additional steps, but I have no “Compress” option. I opened a terminal and created a zip file that way, but when I type “unzip x.zip” it says unzip “command not found”. So, I assume I somehow broke my built in unzip functionality.

I’m a recent convert from Windows, so I have no idea how to restore this option. I do realize this isn’t a Scrivener issue, but my individual machine, so I do appreciate your assistance.

Thanks again,

Jim

– BEGIN ERROR –

7/8/12 10:50:10.193 AM Scrivener: Exception detected while handling key input.
7/8/12 10:50:10.193 AM Scrivener: launch path not accessible
7/8/12 10:50:10.196 AM Scrivener: (
0 CoreFoundation 0x9cdc8a67 __raiseError + 231
1 libobjc.A.dylib 0x90146149 objc_exception_throw + 155
2 CoreFoundation 0x9cd30289 +[NSException raise:format:arguments:] + 137
3 CoreFoundation 0x9cd301f9 +[NSException raise:format:] + 57
4 Foundation 0x9a87d5d9 -[NSConcreteTask launchWithDictionary:] + 506
5 Foundation 0x9a87d3da -[NSConcreteTask launch] + 40
6 ScrAppKit 0x004ef62e -[KBZipManager unzipFiles:fromZipFileAtPath:toDirectory:excludingFiles:options:error:] + 1730
7 ScrAppKit 0x004eef66 -[KBZipManager unzipFilesAtPath:toDirectory:error:] + 79
8 Scrivener 0x00249365 -[SCRTemplateXMLGenerator createProjectAtPath:fromTemplateAtPath:error:] + 844
9 Scrivener 0x0019748b -[SCRTemplatesPanelController createProjectSheetDidEnd:returnCode:shouldSubstituteTemplateTags:] + 1640
10 AppKit 0x9278acd7 -[NSSavePanel _didEndSheet:returnCode:contextInfo:] + 317
11 AppKit 0x924adf52 -[NSApplication endSheet:returnCode:] + 337
12 AppKit 0x92787b31 -[NSSavePanel dismissWindow:] + 154
13 AppKit 0x92789799 -[NSSavePanel ok:] + 464
14 CoreFoundation 0x9cd1dd11 -[NSObject performSelector:withObject:] + 65
15 AppKit 0x922eb86f -[NSApplication sendAction:to:from:] + 232
16 AppKit 0x922eb74c -[NSControl sendAction:to:] + 102
17 AppKit 0x922eb64f -[NSCell _sendActionFrom:] + 160
18 AppKit 0x9251223a -[NSButtonCell performClick:] + 828
19 AppKit 0x9257d985 -[NSControl performClick:] + 40
20 AppKit 0x923572f2 -[NSButton performKeyEquivalent:] + 373
21 AppKit 0x92356e6b -[NSView _performKeyEquivalent:conditionally:] + 49
22 AppKit 0x92357160 -[NSControl _performKeyEquivalent:conditionally:] + 142
23 AppKit 0x92357058 -[NSView performKeyEquivalent:] + 340
24 AppKit 0x92356e6b -[NSView _performKeyEquivalent:conditionally:] + 49
25 AppKit 0x92357058 -[NSView performKeyEquivalent:] + 340
26 AppKit 0x92356e6b -[NSView _performKeyEquivalent:conditionally:] + 49
27 AppKit 0x92357058 -[NSView performKeyEquivalent:] + 340
28 AppKit 0x92356e6b -[NSView _performKeyEquivalent:conditionally:] + 49
29 AppKit 0x92356df2 -[NSWindow performKeyEquivalent:] + 225
30 AppKit 0x9278d0b4 -[NSSavePanel performKeyEquivalent:] + 1397
31 AppKit 0x92836cd5 -[NSTextField textDidEndEditing:] + 870
32 Foundation 0x9a83edf1 __-[NSNotificationCenter addObserver:selector:name:object:]_block_invoke_1 + 49
33 CoreFoundation 0x9cd08903 ___CFXNotificationPost_block_invoke_1 + 275
34 CoreFoundation 0x9ccd3688 _CFXNotificationPost + 2776
35 Foundation 0x9a829fde -[NSNotificationCenter postNotificationName:object:userInfo:] + 92
36 AppKit 0x9289306b -[NSTextView(NSPrivate) _giveUpFirstResponder:] + 460
37 AppKit 0x92875631 -[NSTextView(NSKeyBindingCommands) insertNewline:] + 475
38 CoreFoundation 0x9cd1dd11 -[NSObject performSelector:withObject:] + 65
39 AppKit 0x9277396c -[NSResponder doCommandBySelector:] + 260
40 AppKit 0x9286a446 -[NSTextView doCommandBySelector:] + 152
41 AppKit 0x92a48875 -[NSTextInputContext doCommandBySelector:] + 109
42 AppKit 0x92a44966 -[NSTextInputContext _handleCommand:] + 84
43 AppKit 0x9268174f -[NSKeyBindingManager(NSKeyBindingManager_MultiClients) interpretEventAsCommand:forClient:] + 1721
44 AppKit 0x92a4930e -[NSTextInputContext handleEvent:] + 1389
45 AppKit 0x928ec652 -[NSView interpretKeyEvents:] + 220
46 AppKit 0x9278f939 -[_NSSavePanelTextView keyDown:] + 218
47 AppKit 0x922b3ce3 -[NSWindow sendEvent:] + 10891
48 AppKit 0x9224c163 -[NSApplication sendEvent:] + 4788
49 Scrivener 0x00046b54 -[SCRApplication sendEvent:] + 412
50 AppKit 0x921ddd11 -[NSApplication run] + 1007
51 AppKit 0x9246ebd9 NSApplicationMain + 1054
52 Scrivener 0x0000271d _start + 208
53 Scrivener 0x0000264c start + 40
)

Very strange! I’ve never come across unzip not being present before. First, please open up the Terminal.app again and type:

/bin/echo $PATH

Hit enter - what does it say?

I’m not sure that will tell me much, seeing as zip is working for you (it’s odd that zip works but not unzip), but let’s see what it says.

(It’s also odd that “Compress” isn’t available in your Finder contextual menu.)

Have you done anything to your installation of OS X, such as tweak it for running certain scripts or suchlike?

All the best,
Keith

I found some info that indicating I should try verifying my hard drive. I tried that and found that it had issues (that couldn’t be corrected), so it appears my hard drive image was corrupt.

I reinstalled and now I can open Scrivener fine.

I appreciate all of your assistance in figuring out the problem! I’m looking forward to starting my trial properly now.

Thanks,

Jim

Hi Jim,

Great! Glad you got it sorted, although I’m sorry to hear that it was such a pain to fix and sort out. I hope you enjoy the trial after all that!

All the best,
Keith