Cannot get 11 files to sync up to Dropbox

Hello all,

It’s been the entire day just about, and Dropbox remains stuck trying to sync 11 measly files. Open the package contents of the projects in Dropbox, I can see which snapshot and files they are - they are not unusually large or anything.

I have done Dropbox’s recommended Terminal commands to try and reset it, and I have deleted the cache files as well/restarted etc… to no avail.

Running the latest version of macOS Sierra.

Any suggestions??

I usually just cancel the sync and restart it, until it works. A few files are akways synced and in the end all of them. :slight_smile:

Done that, over and over, without any luck.
Weird part is, if I close the project on my Mac, and open it on my iPad - it pulls down the Dropbox files, and tells me all is updated - but the changes made on the Mac haven’t pulled through - presumably due to the sync not being finished…

Update: It’s now down to 8 files… So 3 synced in 45 minutes. It also appears to be toying with me: “Syncing (8 files remaining, 1 sec left)”… “Syncing (8 files remaining, 45 sec left)”… “Syncing (8 files remaining, 18 minutes left)”… “Syncing (8 files remaining, 1 sec left)” Etc etc. Joy.

[UPDATE:] Still 7 files to go. :open_mouth:

I didn’t get the middle message. Which way is it that won’t sync? I assumed it was from Mac to iPad but now I’m confused.

By the way, do you have the latest version of Mac Scrivener?

I’m looking into things at the moment - I think there is obviously some underlying issue that is throttling uploads to Dropbox.

It won’t sync from my Mac, up to Dropbox. Or rather, it is syncing, but at the speed of photosynthesis…
And because the sync up to Dropbox from my Mac is not finishing, my project over in Scrivener iOS is not updating either…

Running Scrivener 2.8.1 (26322) on Sierra 10.12.4.

But that must apply to all files syncing with Dropbox

This is almost certainly a connectivity issue. Syncing between your Mac and the Dropbox server is under control of the Dropbox software, with no involvement by Scrivener at all.


Thanks Katherine - I figured as much. After the earlier suggestion, I dropped in some other files to Dropbox on the Mac, to get them up - and they too took forever to upload. :cry:

Left my Mac on overnight, and thankfully - all was done this morning, with me being able to pull things down correctly into Scrivener iOS. I will watch things closely to see if I can work out where the possible bottleneck is.

It’s just really frustrating when you spend a day trying to get the smallest changes synced over to the iPad - particularly when it is such a pleasure to be able to review one’s work on it, as opposed to the Mac.

One alternative would be to connect a wire between the iPad and the Mac and use iTunes to transfer projects across.


:open_mouth: Clean forgot about this as an option!
So remove my projects from Dropbox [as in, stop using the Dropbox sync completely] - and then simply sync the old-fashioed way via iTunes?

If things don’t improve in the foreseeable future, this might be a measure of last resort…

Things appear to be back to normal today - made major edits over on the iPad, and the sync took a reasonable amount of time, so hoping it lasts. Regardless, thanks for the suggestion.

Yep. You can move the project back to Dropbox once your connection stabilizes. It should “just work,” but I’d recommend taking an extra backup first, just in case.


I am having the exact same problem.

I’ll try the hardline solution, but just wnated to report this as a problem (started yesterday).


My Dropbox issue resurfaced a few days back.

There are a couple of hundred files, sometimes as few as 10, other times into the high 200s, that just never appear to finish the sync.

Opening the Dropbox/Apps folder in Finder, had two “blue circles” of sync in progress in both 1Password, and Scrivener. No matter what I tried, in terms of restarting/pausing/quitting Dropbox - the sync never finished. It was as if some blockage had occurred, with other Scriverner files syncing ‘around’ the core files that were stuck, but it was not finishing up.

In desperation, I have now removed the two Scriv projects completely from Dropbox, and put them one side. What remains now, are the 1Password files, that are STILL trying to sync. I realise that I can go via iTunes, but honestly, when Dropbox works - it is far more convenient.

To be clear, this is NOT a Scrivener issue per se, but something, somewhere is jamming things. Its as if the sync gets stuck in some sort of an infinite loop.

Opening the Package Contents of the Scrivener project, showed that the few files that were still trying to complete syncing were not “big” by any stretch, a few hundred KBs of text files. The 1Password files were larger, 2mb image files - so that might have been where the issue started. Something potentially interrupted something, possibly while Scrivener was trying to sync, and then it couldn’t complete.

Just to reiterate, I’m not pointing fingers, I am merely popping this up here to possibly shed some light on something that could be affecting one or two others.

I will follow up at 1Password, to see if something can be recommended from that side.

I am pleased to report that I have solved this, for now.

The culprit was two small image attachments that I had added to a 1Password note, on my Mac. Somewhere, the upload was interrupted, and that appears to have been the proverbial spanner in the works.
After removing the Scrivener Projects from my Dropbox folder, the sync almost completed, but remained ‘stuck’ on those two attachment files in the 1Password vault.

I eventually deleted them both, and Dropbox then completed the sync. I have now moved the Scrivener projects back in, and all appears to be working as it should.

Long story short - if others have Dropbox issues, it might be worthwhile to look closely at what else appears to be stuck syncing in Dropbox. I might very well have “solved” this issue before moving the Scrivener Projects out, had I simply deleted the two image files of 1Password that were creating the issue first - or maybe the move was necessary to assist Dropbox in ‘isolating’ the issue - I’m not too sure.

That being said, I’m fairly certain that a similar issue arose when I first started this thread. I will now know to keep a bit of an eye on the
1Password folder in Dropbox, if I change something significant – that requires more prominent syncing – in either the macOS or iOS versions.

Should this happen again, I will try fixing the 1Password sync issue, before going the route of pulling the Scrivener projects.

Regardless, if others have issues, maybe the above can give them some guidance.

Thank you for describing this in detail, you bring up a very useful point.

Dropbox has a bandwidth limit. It’s user adjustable (see the Preferences panel in the Dropbox software), but the basic idea is that Dropbox does its thing quietly in the background, without affecting the YouTube video or the Spotify playlist that have your attention.
So if you have 20 files to sync, maybe only five will actually be in transit at once. Which means that if one of those five gets stuck, everything behind it will get stuck, too.

Now, ideally, what would happen is that the problem file would time out, Dropbox would move on to something else, and ultimately only the problem file(s) would be left. That doesn’t appear to be the case, though, so it’s up to you to experiment if you run into this kind of problem.


Thanks for the explanation - very useful to keep in mind. I set&reset the bandwidth options/paused/restarted/force quit/did Terminal magic to kill setting files - everything short of unlinking and re-linking my account, and nothing. So it can be pretty persistent in its stuckness! 8)

But as mentioned, at least I know what to look for now!