Cannot Hide Scapple

Neither Cmd-H nor the menu item will Hide the Scapple windows.


This works fine for me. Could you please open (from Applications/Utilities) and see if any errors get reported there when you try to hide Scapple?


Nothing gets added to the end of the All Messages window in Console on either the menu or Cmd-H. Hiding works for all the other applications so assuming it is not the mouse or a general setting for Cmd-H.
I am running an unregistered version 1.0.
Oops. Just found that Quitting and Opening the last document caused the Hide to start working again.

Hmm, that’s weird. What if you search the Console for “Scapple”? The error might have got thrown earlier, causing erratic behaviour.

Occurrences of Scapple in Log

051113 9:22:56.834 PM KeyCue: *** process changed (B) from Process “Scapple” (SCPL) 1.0 to Process “DragThing” (Dock) 5.9.9

051413 7:00:00.705 AM Scapple: Error loading /Users/tomm/Library/ColorPickers/RCWebColorPicker.colorPicker/Contents/MacOS/RCWebColorPicker: dlopen(/Users/tomm/Library/ColorPickers/RCWebColorPicker.colorPicker/Contents/MacOS/RCWebColorPicker, 265): no suitable image found. Did find:
/Users/tomm/Library/ColorPickers/RCWebColorPicker.colorPicker/Contents/MacOS/RCWebColorPicker: no matching architecture in universal wrapper

051413 7:00:48.905 AM KeyCue: *** process changed (A) from Process “Scapple” (SCPL) 1.0 to Process “Safari” (sfri) 6.0.4


The log tells us two things:

  1. You have a colour picker plugin on your system entitled RCWebColorPicker (a quick Google suggests it’s from here: ) which is not compatible with universal apps (i.e. it’s very old). I would recommend deleting this colour picker.

  2. KeyCue ( ? ) is causing some app switching.

It’s possible that either of these could be the issue - especially seeing as KeyCue has something to do with keyboard shortcuts - but also possible that they are both unrelated. If the issue is persistent, I would suggest ensuring that the colour picker plugin is deleted and that KeyCue is turned off and test to see if that helps.

All the best,