Cannot import from Word to Mac at all

Hello-

I have tried all the methods outlined in the manual and have in fact been able to import using this same method before, but when I use any of the following, the beachball spins either indefinitely (on my laptop) or it spins for a while and then stops, but nothing has happened.

I have tried:
Import
Import and split
Drag and drop - this says it is converting and then the icon of the dragged file returns to the desktop
Copy and paste - I copy a section of text and paste and nothing is pasted.

HELP! I believe there was an update in the past week and since then I have been completely stopped. My editor works in word so I have to move files back and forth all the time. I can’t sacrifice the formatting by going to rtf. I have tried saving as .doc instead of .docx, but nothing has helped.

I am now able to copy and paste, but only very small chunks- sometimes as much as a page, but sometimes I have to break sentences down and paste them over a few words at a time. As I’m working on a book length project, this is not sustainable.

Perhaps:

Slàinte mhòr.

From Word, try saving as an RTF file and importing that to Scrivener instead of the .docx file.

What’s special about the formatting?

We haven’t seen reports that indicate this is a general problem, but there are some things that Word can do that have no equivalent in Scrivener.

Katherine

I’m having a possibly-related problem importing a word document (as .docx or as RTF) that contains numerous comments.

The file is a novel manuscript that my editor has annotated extensively—novel runs to 113,000 words, but editor has inserted 524 comments (per Word 16).

If I save as RTF without comments, the manuscript imports into a new project in Scrivener 3.1.2 (10882) on macOS Mojave in a couple of seconds at most.

If I save as RTF with the comments, the import process hangs (showing floating window titled “Import” and “Importing 1 of 1” with progress bar showing it’s complete). This happens with both the old (Java) converters, or the native in-house file converters (as per earlier comment on this thread).

(Note that I’ve accepted all changes and turned off change tracking in Word prior to saving the file I’m trying to import—so it appears to be a comment-related problem, not change tracking. Copy of the file I’m trying to import available via private email.)

UPDATE

I took the saved RTF version without comments and added a single comment to the test file. It imported fine. (I’m not able to time the process, though, so I don’t know if it’s adding a delay.)

Further update

I finally got my MS to import, with comments, by going back to the original and not accepting all changes. (Now trying to work out what, if anything, I’ve missed …)

I’m greatly relieved to advise that the method proposed by JoRo (Preferences > Sharing > Conversion > turn OFF Use enhanced converters…) has worked for me this evening. I tried repeatedly importing both a MS Word doc and a RTF copy of it and both were failing miserably with the import dialog either becoming a modal box and hanging, or appearing to complete but failing to import (depending on the import method selected).

The change to avoid the enhanced converts seemed to work a treat. Thank goodness.

Hello,
I have been unable to import large word documents (40 pages and up), full of images, tables, and comments. I’m editing a large book, and I usually export and import the documents back to and from Word, in order to edit on Scrivener (my author only uses Word). I had previously imported succesfully four chapters (a few weeks ago), smoothly, as always. Yesterday I was just going to import the other three chapters, and it just takes forever, and, in the end, Scrivener can’t import them at all. I tried importing a single page document, without problems. So, the problem is not the importing feature itself, but importing large, complex documents. I also used two different computers. Both are powerful, one is even more powerful than the other; there’s no difference.

I tried both .docx and .rtf files. Same result, unless the document has been deprived of all images, and comments. But I need them both.

I also tried activating and deactivating the import method suggested in this thread. It’s not working either way: with the Java or the new decoding engine.

Finally, I tried to import again one of the RTF files I had already imported weeks ago: same result. It just can’t do it. So it’s not something that happened with these files; it’s something on Scrivener.

Any suggestions? I would really need to fix this, not just for this project.

Thank you!

I used the suggestion below and was able to keep all my comments- I also had a lot of comments from my editor in the word doc that I was trying to keep. My document was about 20 pages, so perhaps saving yours in two halves would solve the issue? Good luck!

In my case, I had already tried this solution, and it didn’t work either. My point is that I’m trying to do now something that I have done many times, smoothly, without issues. I’m actually trying to do it again with complex documents that I had already imported succesfully; but now I can’t import them again. Therefore, something else is wrong. It’s not the document itself. Scrivener is a very powerful tool. This hasn’t posed a problem in the past. Therefore, there’s a real technical issue behind this odd behavior. My guess is that it has to do with this new importing method.

I had a problem the other way, making a Compile Format for .docx, which kept failing in the sense that setting it to open automatically in Word gave “file is corrupt” alert, though when the compiled file was opened from the desktop Word said “Do you want to open it anyway?” When it did, one of the images was missing. I sent a trial project to Keith with that image in it … it turned out that using his exporter Word doesn’t like embedded image file-names with spaces in them. He wrote to me that he has dealt with this for the next update.

I’m telling you this, because it seems to me that there may be similar issues on the import side of his new converter. If you have any way of isolating where the block is happening and can send Keith a cut down version of the ,docx including it, or failing that, giving him access to the .docx itself, he will have a much better chance of identifying what’s going wrong and solving the problem.

:slight_smile:

Mark

I get your point, but this is happening with seven different documents, more than 40 pages long each; four of them that I had already imported successfully. Isolating the problem will be a long road.

Oh, believe me, I totally appreciate that. But can you not find a way to give Keith a link to a couple of them? If it were me, I’d give him access to one that formerly imported successfully and one of the ones that has never imported. If he has examples that fail, he has the technology to spot why they are failing.

If they are too sensitive, can you not try redacting them, doing a few character substitutions to make them unreadable?

:slight_smile:

Mark

All right. It’s just I think that the problem is not the document itself, but the whole thing. Actually, I think that if I install an older version of Scrivener I might fix everything. If it doesn’t, I would have to turn to Word and find out if they made any changes as well. I’ve already sent Keith an e-mail and see what happens. Thank you.

Well, let’s hope that Keith comes up with a solution in good time. I seem to remember him saying in the past that writing his own converter would be a huge undertaking; he’s obviously bitten that bullet, and the more information we can give him about bugs/glitches and other unwanted outcomes, the better.

:slight_smile:

Mark