Cannot Paste Text

Just bought and installed Windows 3.0.1.
Fairly experienced Scrivener Mac user (3/5, was a 4 before new Compile).

I can repeat this behavior:

Open text file outside of Scrivener (ctrl-A, Ctrl-C)

Open existing Scrivener project

Create new document (click on plus)
Name it.
Try to past text–paste/editing options greyed out.

Open instance of Notepad.
Ctrl-V pastes texts.

Repeat, same result.

It’s like editing has to be turned on.


Found the answer by accident.

The editing area does not begin in the upper-left hand side at the top of the document but in the middle of the document.

I don’t know why this is so, but OK.

I don’t have the rulers showing–assuming that they exist–so that’s why I didn’t recognize this behavior.

Umm, fixed width editor by any chance?



@Mark: I don’t think you can call Scrivener a fixed-width editor. The default margins were narrow so I tried to place text outside them, of course that wouldn’t work.

I believe that @xiamenese is referring to the “fixed width editor” option in Preferences /Options. On Mac, this checkbox is found in the Preferences dialog, Appearance pane, Main Editor selected in the sidebar, Options tab. I assume it’s in a corresponding position in Windows’ Options dialog.

Anyway, it’s on by default in v. 3.x, but it wasn’t in v. 2.x Mac or v. 1.x Windows. If you ever changed it on your Mac, it was probably so long ago that it’s slipped your mind. :wink: I suggest looking at your options and turning this one off if it’s on. Does that help?

Could be. But I generally like the wide margins so I’ll stick with what I have. Thank you for answering.

You’re welcome!