Can't access old files after upgrading to 3.1.1.0

I upgraded to 3.1.1.0 on 11-3-21, and I can still access projects back through 08-21. But all my projects before that invoke an error message “Can’t access [name of file]”. Any suggestions??? Thanks

Hi dseiple. Welcome to the forums. It’s difficult to diagnose without more info.
The first questions that hit me are:

  1. What version did you come from? (was it 1.9?)
  2. What is the extension to the file you’re opening? It should be “.scrivx” (not to be confused with the parent folder which has “.scriv” at the end.
  3. Maybe providing a screen shot of the contents of the folder in which your project sits.

You may know this, but Scrivener 3 will upgrade the 1.9 projects upon opening them. Did that happen? Do you have a backup of the 1.9 versions before trying to open them?

All these answer may help us figure something out.

Hello GoMach
Thanks for the quick reply!

  1. Yes, my old version was 1.9.16, and I can still open all of my old files from my old computer via 1.9.16
  2. All of the files appear to have scriv extentions… however…
  3. …I will try to include the screenshot here. (My attachments keep getting rejected but I’ll try to upload it again after this message gets sent.) On the attachment you’ll see a series of 6/9/21 files, and all of these files were transferred to my new computer as of that date – all of which (save but one you’ll notice) appear to have scriv rather than scrivx extensions. Moreover the files I CAN open, below that, also appear to have scriv rather than scrivx extensions.

3a. I can open any file on my new computer that appears below the last of those 6/9/ dates – in other words, any file that I created on my new computer. I must have converted to Scriv 3 just before 8/13 , The last of the files I can open on my new computer is the third highlighted file. I can’t be sure why the file “Philosophy as a way of Life” (not highlighted) has a date of 7/13, though I suspect I may have tried to open it on that date. In any case, I still can’t open that one either.
3b. However, you’ll also see two files above this that are also highlighted. The first was was originally Art1.scriv, which I changed to scrivx on 1/15. But I still could not open it on my new computer. Also with Aumann letter 1.scriv. I erased the “scriv” extension to see if that made a difference, but it didn’t.

I did get another error message eventually, which I neglected to screen-catch, which said there was a conflict possibly with the filename display on an icloud storage, and yes I do use OneDrive with an auto-update function, so that may be the problem. But I followed its directions to choose a format, and then tried opening the file – but still couldn’t.

So there you have it. Sorry about this tedious detail.

Thanks for helping.

– David

P.S. I’m sorry I can’t figure out how to upload attachments here. It keeps rejecting my efforts.

Does that mean it’s off the disk until needed? If so, turn that option off.

If OneDrive works the same as Dropbox, you can turn it off on a folder-by-folder basis, in which case you could turn it off for a folder containing all your projects. If not, you’d have to turn it off entirely or expect some weird results.

1 Like

I can’t be sure, but this may reinforce that @drmajorbob is on to something.
Are you using a service like DropBox, Google Drive, OneDrive or another like that?
IF SO, be SURE it is set to always STORE the files locally (and not stream them as needed).

For attempts at uploading, are you using the upload icon in the window used to compose a reply?

Hi.
Last time I had a somewhat similar issue after an upgrade of Scrivener, it was caused by my antivirus (AVG) [Avast is known for causing this too]. I had to set a ransomware permission for Scrivener after which all worked fine.
(Unfortunately, all my screenshots of the event were lost in the transition to the new forum → It would be useless to link to the thread.)

Thanks to everyone for the comments.

@drmajorbob : I tried pausing the OneDrive sync, but that made no difference. I’m not sure what else I can try on this. I do remember that I had trouble access Word files after I transferred to the new computer, having something to do with an auto-date function added to the file name. Erasing that solved the issue, and some of the problematic files in the Scrivener projects have those as well. But deleting those dates does not solve this problem.

David

Yes I’m using OneDrive, but the files in the OneDrive folder I’m having trouble with are accessible locally already, so I guess that’s not the problem.

And as for the attachments, I’ve tried the upload button on the bar of this composition space and as well drag and drop. I’ve tried sending jpeg and I’ve tried pdf, neither of which has been a success yet. The attachment shows up fine in the mirror on the ride side, but when I try replying, it says I “can’t embed media items in a message.”

Thanks again.
David

Could this be something as simple as a read only status for files imported on your new computer ?

I do have AVG, and I’ve just added an exception for OneDrive, but that turns out to make no difference on retrieving the files.

I just tried your suggestion as to the read-only property, and yes I was able to remove it. Then I was able to access the file, but unfortunately most of the text was erased.

Thanks for sticking with this!

The AVG exception/permission should be for Scrivener, not for OneDrive.

As for your text being erased : knowing what you know now, you can still retrieve your Scrivener projects from your other computer using a USB key, then remove the read only once you transferred them to your new computer. That should work.

Even better, have Scrivener back them up (one by one, on your old computer) in ZIP format ; then transfer this to your new computer, unzip and remove the read only.
If your old computer has no text missing, I can’t see why the cloned version of your projects in your new computer then should.

→ Also (I just though of it) check see if the “read only” was also removed for the content of your Scrivener’s project sub-folders…[and files too] (That might explain the missing text.)

1 Like

Yes, these are excellent suggestions. Much appreciated.

You’re welcome.

Now, I strongly recommend that you remove the OneDrive permission from AVG.

That’s the opposite of what I suggested.

So, @dseiple… any success ?