Can't change font

No matter what I do, I can’t seem to escape Scrivener’s default font for the main editing and writing window. I’ve tried and tried to change it in the preferences window, both under the “fonts and colors” and “text editing” tabs. I suspect that “text editing” is the place I need to be to change the main window, but when I click on “set font” a window opens with all sorts of font and size possibilities but no button to apply them with. What am I doing wrong? Many thanks.

Have you followed the instructions in the FAQ for changing the default font? It is key to note that the preferences set up how new documents will be configured. It has no control over existing documents (as mass conversion results in occasional format loss). You need to manually update the old documents using the conversion tool. Again, consult the FAQ for instructions.

thanks, Amber. Yes, I’ve been all through the FAQ. I’ve been trying to reformat the font on a new
document within an existing project, and no luck. Anything else I can try?

Could you describe in a step-by-step fashion where the process fails? Here is what happens for me—what should be happening for you:

  1. I press Cmd-, to open preferences, and click the Text Editing tab to change the default font.
  2. Below the area with the ruler and sample text is a “Set Font…” button. I click that and get the window you described.
  3. At this point, clicking any font choices within this window should immediately change the descriptive text describing the font, such as “Courier New, 12pt”, and the sample text should also change immediately.
  4. Once I get it set up the way I like, I close the font palette, and then click “Ok” on the preferences window.

Now create a new document and it should have the new settings. Are you not seeing step 3 happen?

Aha! I finally got it. The problem was that the sample font window kept jumping back to the default font after I changed it. I must have somehow been too quick on the trigger to open a new document. The problem is now solved. Thanks again.