Can't disable Typewriter Scrolling in Full Screen mode

Hi guys,

This has been annoying me for some time: I just can’t disable TypeWriter Scrolling in Full Screen Mode! I tried everything I can think of. I turn it on and then turn if off, there is no scrolling in regular mode, but as soon I as get back in full screen mode, the typewriter scrolling comes back and I can’t get rid of it. I changed the keyboard shortcut to ctrl+shift+t (and removed a conflictual shortcut), and it has no effect while in full screen mode…

I just can’t get rid of the typewriter scrolling. Please, let me know if there is anything I can do on my side, or if it’s a bug or whatever.

Thanks,

Michael

PS. Running 1.5.7.0.

Not all shortcuts can work in full screen, unfortunately, so I’d try first resetting the Typewriter Scrolling shortcut to the default and then going into full screen and trying it again. Hold the Control key while pressing G and then T. This should be working, but you need to do it while in FS, since the mode applies to each editor individually.

You may also want to disable the setting in the Editor tab of Options that has new projects start with Typewriter Scrolling enabled in Full Screen, but that will only affect future projects so you’ll still need to use the shortcut from within FS to disable it for your current project.

I don’t understand. Ctrl+G+T? Hmm.

I’m trying to reset the keyboart shortcuts, but it’s not working. I have no idea why. In the Keyboard tab, I press the Reinitialize all (or whatever it’s called in English), and it doesn’t reset the typewriter scrolling to what it was at all. It keeps the Ctrl+Shift+T I set just an hour ago. But I had to change the keyboard shortcut first because it was Ctrl+Meta+T or something like that, and I have no idea at all that this so-called ‘Meta’ key is?!

That also brings me to another problem, but not related: since the last updates, I can’t get Scrivener interface in English anymore. I choose ‘English’ on the General option tab, Scrivener restarts and it’s still in French, even though it says English in the language tab. (I write in French, but I prefer to keep the software in English because the translation is incomplete + it is easier for communication). No biggie, though. It’s really the typewriter scrolling that’s bugging me.

To reset the shortcuts, select the “Scrivener” option from the Import button menu in the Keyboard tab. Ctrl-Meta-T was the previous shortcut, but that was changed along with some others in a recent update to provide better functionality. The new shortcuts follow patterns from Visual Basic and other programs that offer a plethora of shortcuts, so they are either in the form Ctrl+G, N, meaning that you hold the Control key while pressing G, then lift off both and press the second letter N, or Ctrl+G, Ctrl+N, meaning that you must have the Control key depressed while typing both of the letters. The new typewriter scrolling shortcut is Ctrl+G, Ctrl+T and this works in full screen as well as each of the split editors in the main window.

The interface issue I’ll have to look at separately, so I’ll get back to you on that.

Thank you so much for your help, MimeticMouton. Unfortunately, the shortcut doesn’t seem to work in full-screen and I have no idea why. I reset the shortcut, it is back to Ctrl+G, Ctrl+T. It works in regular compose window, I can turn it on and turn it off with the shortcut, no problem there (I tested it there to be sure I was doing it correctly). But doing the same thing in full screen mode seems to have no effect at all.

Why is there no option for this in the Options panel? Or even in the bottom full-screen bar, just a check-box to activate or deactivate it? Or why does deactivating it in regular compose mode doesn’t deactivate it in full-screen too? I must admit this is driving me crazy every time. I seemed to have succeeded in deactivating it in the past, but since I installed 1.5.7.0, nothing seems to do it.

The setting deliberately affects each of the editors individually, since you may be using each for a different type of writing and want the typewriter scrolling in one but not another. Ideally yes, you’d be able to access the menu from Full Screen and could check or uncheck the option there just as you can do in the main window; since that isn’t possible yet, I’ll see if it may be doable to modify the control panel at the bottom of FS to include this option for the time being. Meanwhile, the shortcut should be working, but since it’s not, my suggestion then is to try temporarily resetting it to something else you know is working for you in FS, like Ctrl+C or such (assuming it is working). Remove the shortcut from the command it’s currently assigned to, set it for typewriter scrolling, use it to disable TW scrolling in Full Screen for any existing projects that you want it off for, then reset the shortcuts as you wish. Then make sure also you disable the command in Options to have new projects start with TW scrolling in full screen, to avoid having to redo this for future projects.

I just tried what you suggested: temporarily assign Ctrl+V (which is working in FS to paste stuff). It works in regular compose window: I can turn on/off typewriter scrolling by pressing Ctrl+V. But as soon as I enter FS, I press Ctrl+V and it just pastes the last thing I copied. It’s like the keyboard shortcuts changes aren’t taken into account by full screen mode…

That said, I give up. I lost too much time already and will have to live with typewriter scrolling for now and concentrate on the writing. It’s possible I’m doing something wrong, but I’m pretty careful in following the instructions you said.

Thank you very much for your help, it is much appreciated. If you need me to do some more testing later I’ll be glad to help, but for this afternoon I definately gotta concentrate on the writing. :wink:

Hi mtrahan! I am sorry to hear that you experience problems and cannot disable the typewriter scrolling in Full Screen. We are investigating this issue. Meanwhile you can open the following file: PROJECT_FOLDER.scriv/Settings/ui.uni
At the end of the file you will find the section: [TypewriterScrolling] followed by the line: “full=true”
Please, modify it to “full=false”. This should get the TypeWriter scrolling off. Unfortunately you will need to modify any project having this issue. Meanwhile we will trace this further and provide an update.

Ahhh, thanks! I’ll keep that in mind as it’s not the first time I have this problem and it is much easier to change this setting manually than to change it through the UI. :wink:

Much appreciated! Good luck fixing this problem, and if you need me to test anything just let me know.

Glad it worked. Unfortunately I could not duplicate the problem and it must be connected with your shortcut settings, mtrahan. Most probably the reason for your pain is a Shortcut Collision, which is sometimes not easy to catch. Have in mind that some actions have different Full Screen shortcut and Normal View shortcut and collision might not happen in Normal View, but only in Full Screen view. The best way to catch a duplicated shortcut is to type the shortcut key combination(i.e. “Ctrl+G”) which filters all the shortcuts having this key combination.

“Why does deactivating it in regular compose mode doesn’t deactivate it in full-screen too?”

  • Scrivener for Windows tries to keep track of the typewriting mode for each editor pane and changes the typewriting mode of the current editor pane only. In your case unfortunately you are unable to change the initial Type Writing mode which has been set on startup.

By the way, guys, I just started a new project today. I made sure that “Typewriter scrolling in new projects” and “Fullscreen typewriter scrolling in new projects” was not activated before I created a new project file. It didn’t work… To be able to disable TW scrolling in Full Screen, I had to manually edit ui.ini again.

Not such a big deal now that I know how to fix the problem, but I just thought I would let you guys know that the “new projects” options are kinda not working here.

Thanks again for your time.