Can't disable typewriter scrolling in fullscreen

I believe I am encountering an error in Scrivener where I can’t disable typewriter scrolling when the app is in fullscreen on the Mac.

To reproduce:

  1. Open a scrivener document.
  2. Full screen the app in OSX.
  3. Make sure typewriter scrolling is disabled under Format>Options>Typewriter scrolling
  4. Type text into your document. At this stage everything should be working as expected.
  5. Set text zooming to any number greater than 100%. Eg. 150% zoom. (View>Zoom).
  6. Type text into your document. At this stage the input behaves like typewriter scrolling is enabled, even though it is disabled. Turning typewriter scrolling on or off has no effect.

Let me know if anyone can reproduce this. At the moment my solution is to increase the font size and set text zooming to 100%.

I followed your instructions.

I don’t get the error.

I can zoom to any level and toggle (ctrl cmd t) typewriter scrolling off and on, with it working exactly as it should.

Unfortunately, I have no idea why it doesn’t work on your Mac.

This sounds like a known issue. In my testing, it requires a fixed-width, centred editor (default for full screen) and at least 110% zoom. Even then the glitch only appears sporadically, so some people may never see it. It was also reproduced on a Retina machine running 10.9, but never confirmed if it absolutely requires that setup. We have some further fixes to the editor in the pipeline, hopefully that will clear it up.

I am still having this issue. Everything works fine in regular mode or composition mode, but in fullscreen, even if typewriter scrolling is disabled, the text still jumps around while I’m editing. I hadn’t thought of changing the zoom-- good to know that it only happens when zoom is set to 150% (even 125% seems to work fine.) But it is still annoying --almost the only thing about Scrivener that I don’t love! Hope this can be fixed soon.

Thanks for the note. I played around with it some more and found a few cases where I can reproduce this. We’ll take another look at it.

I have had the same issue and it was never resolved by ‘Typewriter scrolling’ threads. It is not resolved by turning that function on and off.

It just happens sometimes when I amplify zoom (not pressing any keys, or clicking anything else).

Once it happens, in THAT document THAT zoom level will have the jittery scrolling effect for ever more. Problem is not there if I return to other zoom levels.

Irritatingly, I can no longer use 150% zoom in any documents even though it’s my preferred (I’ve never understood why 100% is so small in Scrivener, Word etc.).

Yeah, what you are speaking of is still a known issue at this time. It is on the list to take another look at though. These sporadic ones can be difficult to pin down, and sometimes there is more than one cause.

I can no longer use most of the mid range zooms in my book, without the screen bouncing at the end of every line. And nothin I can do about it.
I would say that is a pretty significant problem with the software!

We’re not entirely convinced it is a problem with Scrivener itself. I am not sure of it, but I think I have seen it happen in TextEdit, and the behaviour itself is quite like what happens when you position your cursor somewhere, scroll elsewhere, and then type. It’s exactly the same behaviour, snapping the view so that the cursor is in the middle of the screen. The main problem is, like I say, reproduction. That is essential to tracking down bugs like this, and I only see it abound 5 to 10% of the time if that, while Keith never sees it at all.