Can't find most recent version of one project.

Windows 10 computer, Scrivener
Help please. Yesterday printer problems caused the need to turn off my computer, disconnect the printer and re-install it from the original disk.
I thought all Scrivener projects were turned off properly, but on going back to one project, it was not found (all others seem intact and open easily), and of course, it would be the one I’ve been concentrating on heavily for the last month.
Went into Tools/Options/Backup (set for 5 most recent) and tried to upload. Each one is a version from over a year ago.Tried to abort saving these, but now have 5, all the same. Unfortunately all working backups are on my computer. When I tried checking Dropbox, realised I’ve never designated it as the backup storage. Luckily, I do have copies of all the chapters (or ideas for them) on my Wattpad library, in draft form until I work on each chapter. There would be other notes and thoughts on my project - not on Wattpad - but at least my main writings could be copied/pasted from there, back into the Scrivener project. Such a big job.
Before I do, just need to ensure there’s nowhere you can think of it could be buried in my computer? Feel I have searched everywhere.

Have you tried a system wide search for .scriv?

That will show all the Scrivener projects on your system.

Thank you NoHope. Really searched every single place I could imagine, and then some - and finally gave up hope (but still desperately needed to continue working on this project). Bit the bullet and copied and pasted all the info. I had on Wattpad. There was more I had in rough handwritten notes (had been in the midst of transferring/re-ordering these to a new multi-sectioned folder when the drama began with my printer first), so they are also helping. Just SO tedious!
I’ve lost some research/links/ideas, etc. but one good thing to come out of it - all of my writing is getting backed up properly in Dropbox now… EVERY time I visit a project.

By that, do you mean you’re saving your zipped backups to a folder in Dropbox now?