Can't get numbered lists to work in compile to epub

I’ve got a numbered list in my manuscript and when I compile to epub it just disappears. I tried adjusting the list behavior in compile/edit format/tables and lists, but it didn’t make any difference. The list was included just fine when I compiled to pdf and Word (.doc).

Am I doing something wrong, or is this a bug?

It’s a bug. The compiler is assigning two classes to the ordered and unordered lists.

I put a pair of lists, one numbered, one bulleted, at the end of a document and compiled it to epub.

In the compiled epub’s code, though, I see this:

[code]

  1. 1. Here’s an entry
  2. 2. Here’s another
  3. 3. Not really an entry?

 

  • 1. Here’s an entry
  • 2. Here’s another
  • 3. Not really an entry?

 

[/code]

So… I took the unzipped code and slapped it into a temporary, complete private website (because I’ve got a really dinky server running for just this sort of thing),

and…
All those lines…

[code]

  • [/code]

    Notice the double class assignment?

    The browser says…

    [code]XML Parsing Error: duplicate attribute
    Location: http://192.168.0.101/test/OPS/body1.xhtml Line Number 110, Column 63:

    1. --------------------------------------------------------------^[/code]

      So of course the ereader is going to ignore those lines.

      After removing (in the website version) the extra class assignment, the browser was able to read it and show it.

      I edited the unzipped epub code, packed it back into an epub file, and tested it.
      Edge would read it, and showed the lists that had been missing. Brackets had a problem with it, and I’m not sure why. I’ve probably missed some essential code somewhere (certainly my manual hack is a bad idea for production, but it worked for the purpose).

      But the bug is confirmed, and even what it is (two classes in one element: forbidden!). Now whether I struck the wrong class (I removed 'class=“scrivener11” from those lines), is a question, but having JUST ONE CLASS for an element is evidently fairly critical.

      Now to figure out why Brackets is choking on it. Sigh.

    Hello, is this still an issue for you or is it now working in the latest beta?

    Appears to be fixed, to me. Two lists, ordered and unordered, and both show correctly as lists.