Can't get revisions to turn off

I decided to use revisions while editing my new book’s first draft. I did find it a bit helpful. However, I’m ready to move to the next stage, and I’d like to remove/resolve the revision color in my manuscript.

It seems from what I’ve read, you would select Format > Revision Mode > None or even Remove All Revisions. However, neither of these things has any effect - which would match a basic user mental model.

I also tried selecting the whole scene and choosing None or Remove and again, nothing.

The ONLY thing that seems to work, is that I can manually select text and manually set the text color back to black. This seems a silly way to work, and if I have to do this - I will have to open and manually change the text color of well over 100 documents. I can’t imagine it was designed like this. Any help resolving this is appreciated.

It is not intended like this.

Selecting “none” will make it that no further edit or text input will have a revision color.

As to removing the revision color from your text, you need to select the text first.

. . . . . .

Why do you have black as your first revision color?
And why doesn’t the red text from your screenshot seem to match your actual revision colors?
If the above doesn’t do it for you, perhaps that is why.

It seems like so many Scrivener features, it works against expectations. Now I have to manually select every document to reset it. It makes no sense to build it that way. I would have never used it in the first place.

I chose RED as my first revision color, not black. As to why they don’t match the colors in the menu - no idea. You would expect black would be your base color - the final color. Revisions would only naturally be some color other than black.

In any editor, I would expect a color to show revised text. I would expect removing revisions, or resetting them, or accepting them, or whatever would result in setting all the text back to default - which would be black.

I guess I’ll have to manually reset it all. What a waste of time. I’ll never use that feature again, I guess.

Select your draft\manuscrpit and display it as a scrivening.
You’ll be able to fix it all in one go.

1 Like

On my system, “Remove All Revisions” works as expected: removes all revisions in the current Editor view.

What version of Scrivener do you have, and with which version of Mac OS?

The colors no longer match. (?)

3.3.1 Mac OS - Mac Version

Thank goodness that worked. Thank you so much.

1 Like

The Revision Mode colors are defined in the Settings → Editing → Revisions tab. I’m not seeing anywhere else to change them.

In my test, manually changing the color of “Revised” text did not un-mark it as revised, but it didn’t change the color of new revisions, either.