Can't get rid of auto-emdash; Preferences don't take?

Hi there. Great program. Played with it for a few hours today and I’ll probably purchase. However, I’m running into a problem that I can’t seem to shake. I’m guessing it’s a problem on my end.

It’s one of those little things that annoys me to no end as a default setup in Word, and now I can’t change it in Scrivener:

Double-dashes become em-dashes no matter what I do. I’ve unchecked, re-checked, and unchecked again both “replace double hyphens with em-dash…” buttons, clicked APPLY, clicked OK, but it just doesn’t seem to take, though my choices appear to have been remembered the next time I open the the Preferences pane.

I haven’t purchased yet. Are preferences crippled prior to registration? Powerbook G4, 10.4.8.

Thanks again.

Alex.

This is very strange - I cannot reproduce this issue at all, and there is no reason I can think of that this would happen. Unchecking “Replace double hyphens in em-dash…” in the Typography pane of Preferences works fine for me, and has done on all computers on which I have tested (including a G4).

Are you talking about during typing only, or upon export?

Best,
Keith

Thanks.

I hadn’t tried exporting yet. Just did. Yes, there’s the emdash rather than the double hyphen. (But if I cut and paste the text into BBEdit, the emdashes become double-hyphens even though I lose all other formatting (sigh)).

Trashing preferences didn’t work.

Aha! It’s an issue with the script modes. Maybe someone can reproduce this:

Creating a new text within the same project yields the same results (double-hyphens become emdashes) UNLESS I switch from Screenplay mode to general mode before I create the new text. So if I start the new text and the last mode I was in was Screenplay or either Stage Play, then even if I switch to general AFTER creating the text, the emdashes (and auto-creation of new emdashes) sticks with it.

I have the default font setup, Optima Regular 13 for General Text and Courier 12 for Script.

I can’t find-and-replace emdashes with double-hyphens because the emdashes read as hyphens to the search mechanism.

Alex.

I could not reproduce this. I did the following:1. Create a new document and put it into Screenplay mode; typed a bit.

  1. Pressed Cmd-N to make a new document; to name it “Untitled”
  2. Clicked in text editor to resume typing; verified that I’m still in Screenplay Mode
  3. Without changing the mode, typed a bit and then tried some hyphen entries. Nothing became em dashes.
    Something comes to mind: You mentioned that the search system considers hyphens to be em dashes, this is not true. Try the following in a blank document: Type some words in, type a double-hyphen, type a few more and then press Shift-Opt- (this manually inserts an em dash). Now try searching in this document for hyphens. The em dash should not match. Try searching for an em dash (you can type it into the search field the same way).

It might be that what appears to be an em dash really is two hyphens. I see your fonts are standard, and should not be doing this (I’ve seen some older fonts do it), but perhaps there is something else going on with your monitor or something. This would explain why em dashes are “magically” turning into hyphens when you paste into a different program – and it would also explain why your search is finding them to be what they maybe really are – just two hyphens lumped up together.

Thanks, Amber.

Huh. I had considered that, and then dismissed it, because opening the exported RTF in TexEdit showed the em-dashes. However, now I think you’re correct.

I created a new file in TextEdit (which I imagine uses the same default resources for displaying fonts as Scrivener). The typing of two hyphens in Courier produces the same effect of instantly shortening/combining to an em-dash as I type, even in plain-text mode. I even enlarged it to 20 point font. It actually happens; it’s not my eyes playing tricks on me.

This doesn’t happen with any other fixed-width font I’ve tested. And it doesn’t happen with Courier or any other font in BBEdit, which is why I didn’t suspect this.

It makes no sense to me why this would happen with ANY fixed width font, but since TextEdit also has the problem, my guess is that this is a system issue which BBEdit avoids with its own way of doing things.

At any rate, it’s something I can work around. While I often need my final printed piece to be in Courier, there’s no reason they have to start in that font. I’m used to doing first drafts in BBEdit using another font anyway. I’ll also look into how old my version of Courier is.

Thanks for your patience. I’ll be purchasing my copy within the next week.

Alex.

…and replacing the font with a newer version of Courier (basically the one in my library/fonts/ dated 2000 with one from an Adobe Application Support folder dated 2002) fixed all issues.

Sorry to have bugged you. Had I ever used TextEdit rather than just BBEdit and Word, I might have known about this issue before today.

Alex.

Huh, well that is a strange one. I wonder if perhaps that old font actually defined two adjacent hyphens in its ligature dictionary. This has the effect of visually and functionally merging two characters, without swapping the characters out for a single one. It would look and act just like an em dash, but still be two hyphens.

I thought of this because the OS X text engine has ligatures enabled by default, and I’m sure BBEdit does not even consult that part of the font table.

Or the font dicts were corrupt.

I think that’s what’s known as bingo.

Dave

Glad you found a fix. :slight_smile: