Can't get rid of first line indent and can't center separator symbols

I’m trying to compile a project as an epub3 file. So far I’ve got it almost the way I want it, with the exception of two minor but persistent issues.

The first is that I can’t get rid of the line indent on the first paragraph of the text file (section type: scene), which follows my copyright page, (section type: N/A). However, the first line of the first paragraph of each subsequent text file doesn’t have the indent.

The second is that the three asterisks I have as scene separators sit on the left rather than the center of the “page,” where I want them.

I’ve checked and unchecked a number of the boxes in Text Layout, hoping to correct these problems, without success.

Many thanks!

If you inserted those directly to your scenes in the editor, the centering gets overridden at compile.
You can either assign a style to those, set them to preserve formatting (see screenshot below), or have the compile format insert them for you (although if you already have them where you want them in the editor, might as well keep them as is – less work).

image

image
(See the pale blue box… that text won’t be reformatted at compile. The font will stick too, which could be a problem, but not really in the case of asterisks. Else, set them to the right font yourself, in the editor.)
I personally much prefer the “use a style” approach, as you can tweak it the way you want in the compile format.


As for the indent of the first paragraph, the settings are here:


…but I can’t tell exactly what you’d need to change or how that would affect the rest of your book.
Again, perhaps use a style in the editor for that said paragraph, which will override the indent from the compile format’s section layout’s formatting for that sole paragraph.
If you later need to change that paragraph’s font, formatting or whatever, you’ll have to add that style to the styles panel of the compile format, and tweak it there to match the rest of the book’s font, formatting etc.

→ Note that both my suggestions are workarounds, and not really the way things are intended to be done.

This is a known bug.

1 Like

The preserve formatting didn’t work unless I put a carriage return before the first line.

In any event, I finally got the formatting exactly how I wanted it by checking the last three options in Text Layout in Compile and by entering the asterisks manually in the text itself.